Go Back   Jaguar Forums - Jaguar Enthusiasts Forum > Jaguar Models ( Modern ) > X-Type
Sign in using an external account
Register Forgot Password?
Search

X-Type 2001 - 2009

Welcome to Jaguar Forums!
Welcome to JaguarForums.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Jaguar Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-11-2009, 05:53 PM
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default door lock problem

The problem started with the passenger door not being able to unlock when pulling the interior handle and i had to pull the drivers handle to unlock the whole car. It has now developed into none of the front interior handles working at all and the only way I can unlock the car is by taking the key out of the ignition and using the remote.
I used to have auto locking activate, i have disabled this using the method on one of the other threads.
It is driving me mad at the moment as i like to have the doors locked when i am driving.
Please help me!
this is the symptoms i have so far.
when i am in the car before i have started driving, i can lock and unlock it using the interiors handles fine. but it seems to activate the deadlocks after driving for a bit. i pull on the locking part and there is resistance and it just springs back, (the same as if i press the lock key on the remote twice to activate the deadlocks), then i have to use the remote to open them.
Weirdly I can still open the rear doors, but it does not open the rest of them.
Reply With Quote
  #2  
Old 11-11-2009, 05:54 PM
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It's a 2001 2.5 saloon if that makes any difference
Reply With Quote
  #3  
Old 12-01-2009, 05:40 PM
Junior Member
 
Join Date: Nov 2009
Location: Suva, Fiji
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Any progress so far I am also having some problem. It just started off last week. I guess it has something to do with the car battery. I had it changed last week, may be something to do with programming...................
Reply With Quote
  #4  
Old 12-01-2009, 06:18 PM
Green Machine's Avatar
Senior Member
 
Join Date: Apr 2008
Location: Lincoln, NE
Posts: 446
Thanked 17 Times in 16 Posts
Angry

I just started having a problem with my doors locking with the remote this afternoon. After washing the Jag and drying it all out around the doors, hood & trunk, I tried to lock it with the remote. It wouldn't lock and the horn sounded twice and 4-2ways blinked twice. I opened and closed each door, hood trunk and even the gas door several times thinking one of them was indicating to the system to not be latched. All to no avail hit the remote lock button results were the same, and there is no message on the message center saying something is open. I can lock them using the key but when I do the horn sounds and 4-ways flash twice, which I don't remember happening before when using the key.
Anyone out there with an idea of where to start checking for the problem?
This sort of ticks me off a bit, since we just returned home Saturday after a 3600 mile road trip, that came off with out a single hitch, now this aggravating little problem.
__________________
BobN
***ALL BRITISH STABLE***
2003 X-Type BRG 2.5 Auto (Green Machine)
1997 XK8 White Auto (White Lightnin')
1964 Triumph Bonneville T120R (Original Owner)
Lincoln, NE
US of A
Reply With Quote
  #5  
Old 12-02-2009, 07:14 AM
The Chris X's Avatar
Veteran Member
 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 2,473
Thanked 125 Times in 119 Posts
Default

talky you probably need to have your door handles R&R'd. It is not uncommon for your condition to occur to do a fastner/cable issue inside the door panel. I had mine replaced under warranty. I believe there are some good posts on this board explaining the problem in detail - do a search.
__________________
03 S Type R - Mafioso Intake+K&N, Akebono pads F&R
07 SAAB 9-3 turbo - BSR Intake/Downpipe, ECU tune, Powerstop rotors and pads
07 Jeep WK 4.7 2" BDS Lift, skids, bull bar, AT3's
06 Jeep XK Commander Limited 4.7 - K&N FIPK, Mopar Skids, Cooper AT3's - planning air suspension
Ex 2002 X Type owner
Member JCOP
Reply With Quote
  #6  
Old 12-04-2009, 05:32 PM
Member
 
Join Date: Mar 2009
Location: USA
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Green Machine - any luck on resolving this problem? Mine just started doing the same thing. Can only unlock using the key in the driver door, and then manually locking/unlocking each other door. Can't get trunk to open at all unless I climb into trunk via back seat and pull the emergency release.
Reply With Quote
  #7  
Old 12-04-2009, 07:46 PM
Member
 
Join Date: Mar 2009
Location: USA
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default locks not working at all

Green Machine - mine turned out to be a blown fuse - 15 amp fuse, #24 in drivers side engine compartment fuse panel. Mine blew a second time right away, but the third fuse seems to be working ok, for now (only been a few hours).

Good luck.
Reply With Quote
  #8  
Old 12-04-2009, 11:59 PM
Green Machine's Avatar
Senior Member
 
Join Date: Apr 2008
Location: Lincoln, NE
Posts: 446
Thanked 17 Times in 16 Posts
Talking

I noticed something else after I wrote my first message.

While the unlock on my remote works, all door unlock with the first push of the button. This instead of just the drivers door with the first push and the other doors on the second push. I don't think my problem could be something as simple as a fuse although I've learned to never say never when dealing with cars etc. I have a feeling though that it's just a glitch in the system and will eventually work itself out. It did this once before but straightened itself out within a very short time. It's too cold now here in Nebraska to mess around trying to fix it. So as long as I can lock and unlock it, I'll just let it have it's way.
__________________
BobN
***ALL BRITISH STABLE***
2003 X-Type BRG 2.5 Auto (Green Machine)
1997 XK8 White Auto (White Lightnin')
1964 Triumph Bonneville T120R (Original Owner)
Lincoln, NE
US of A
Reply With Quote
  #9  
Old 12-05-2009, 11:31 PM
Green Machine's Avatar
Senior Member
 
Join Date: Apr 2008
Location: Lincoln, NE
Posts: 446
Thanked 17 Times in 16 Posts
Default

It appears that my problem might be caused by one of the lock sensors not indicating latched closed. How can you trace down something like this? Also I've noticed that when I unlock the doors with the remote it's doing it in the one stag mode opening all doors with on push of the button. If I use the key to unlock the doors it also does it in the one stage mode. From the time I bought the car 2 years ago until this problem came up it's always been in the 2 stage mode. It made the change in modes on it's own. How do I get it back into the 2 stage mode again after I find out which sensor is messed up?
__________________
BobN
***ALL BRITISH STABLE***
2003 X-Type BRG 2.5 Auto (Green Machine)
1997 XK8 White Auto (White Lightnin')
1964 Triumph Bonneville T120R (Original Owner)
Lincoln, NE
US of A

Last edited by Green Machine; 12-05-2009 at 11:39 PM.
Reply With Quote
  #10  
Old 12-07-2009, 01:58 AM
Junior Member
 
Join Date: Nov 2009
Location: Suva, Fiji
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem I am facing is that all doors get locked as soon as the car starts moving(driving) and thereafter it become very difficult to unlock all doors from inside by using driver door. On the other hand if I am sitting inside the car and I don't move(drive) it or just start the engine and sit inside I can lock and unlock centrally from the driver's door without any problem. This thing only happens when the car starts to move and it get locked by itself. mechanically I had it checked but could not find any problem. It has something to do with electronics or programming I guess. So please any help please.........
Reply With Quote
  #11  
Old 12-07-2009, 09:26 AM
The Chris X's Avatar
Veteran Member
 
Join Date: Oct 2008
Location: Pittsburgh, PA
Posts: 2,473
Thanked 125 Times in 119 Posts
Default

they are all supposed to lock when you start moving. I don't know if this was changed at some point in time but my 02 has done it since day 1, as designed I believe. Yes the lack of an unlock/lock button inside is an odd oversight, but a pull on the drivers side latch should open all the door locks.

You just have to practice and beat your passengers to the handle when exiting the car.
__________________
03 S Type R - Mafioso Intake+K&N, Akebono pads F&R
07 SAAB 9-3 turbo - BSR Intake/Downpipe, ECU tune, Powerstop rotors and pads
07 Jeep WK 4.7 2" BDS Lift, skids, bull bar, AT3's
06 Jeep XK Commander Limited 4.7 - K&N FIPK, Mopar Skids, Cooper AT3's - planning air suspension
Ex 2002 X Type owner
Member JCOP
Reply With Quote
  #12  
Old 06-25-2010, 02:38 AM
tauwheed
Guest
 
Posts: n/a
Default

If you want to swap between 1 stage and 2 stage, you need to press lock and unlock button both together and keep depressed for about 4 seconds. Hopefully this shall solve your problem with stage swapping provided that there is no other related problem existing.
Reply With Quote
Old 06-25-2010, 02:38 AM
 
 
 
Reply



Tags
2001, battery, car, door, doors, drivers, driving, jaguar, jump, lock, passenger, problem, problems, short, stype, type, unlocks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 07:17 PM.

Copyright © 2010 Internet Brands, Inc. All rights reserved.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014 vBulletin Solutions, Inc. All rights reserved.
JAGUAR and its logo are the registered trademarks of Jaguar Cars Limited. Jaguar Cars Limited is not affiliated with JaguarForums.com.