Go Back   Jaguar Forums - Jaguar Enthusiasts Forum > Jaguar Models ( Modern ) > X-Type
Sign in using an external account
Register Forgot Password?
Search

X-Type 2001 - 2009

Welcome to Jaguar Forums!
Welcome to JaguarForums.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Jaguar Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-20-2009, 05:38 PM
Member
 
Join Date: Dec 2007
Location:
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default FAULT CODE P1647

Hows it been guys. Been a while for i am in the military i come and go at all times. Well i get in my little kitty today and i get a check engine light. Checked out the fault code and says P1647 manufacture control computer output circut. Whatever that means. Looked around and it has something to do with the O2 sensors. I had them all changed less than 6 months ago. With the fast knowledge out there i know someone can help. I am in Miami and the the nearest place is the Collection which is little pricey. If i can do it myself great!


let me know

thanks


Reply With Quote
  #2  
Old 01-20-2009, 05:57 PM
Junior Member
 
Join Date: Aug 2008
Location: Canada
Posts: 15
Thanked 0 Times in 0 Posts
Default RE: FAULT CODE P1647

I've foundhttp://enginelighthelp.informe.com/j...ank-2-dt5.html site helpful for a couple of things and this link is directly related to your code.
Reply With Quote
  #3  
Old 01-20-2009, 06:08 PM
Member
 
Join Date: Dec 2007
Location:
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default RE: FAULT CODE P1647

roger i saw that but nothing how to fix it
Reply With Quote
  #4  
Old 01-20-2009, 06:12 PM
Member
 
Join Date: Dec 2007
Location:
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default RE: FAULT CODE P1647

ok excuse me i take it back i thought i been to that site before. so basically it might be a loose connection to the oxegen sensor. so next thing is which bank is which banck one or two how we number our oxegen sensors? which is which
Reply With Quote
  #5  
Old 01-20-2009, 07:59 PM
Real_Tech's Avatar
Photobucket
 
Join Date: Jan 2009
Location: Motorcity
Posts: 526
Thanks: 0
Thanked 24 Times in 8 Posts
Default RE: FAULT CODE P1647

Bank 2 is the bank closest to the radiator. The first thing I would check is the wiring to the sensors for that bank. The harness connectors for both the upstream and downstream o2 sensors are connected to a sheet metal bracket in front of and below the battery. The connectors should be attached to the bracket and the wiring should be routed through a clip arrangement attached to the cooling fan shroud. If the harness has become displaced from the clips on the shroud or the connectors are displaced from the metal bracket the wiring can be fouled by the fan. If that checks o.k. check the fuses for the o2 sensor heaters. I don't have an electrical guide in front of me but I believe the fuses ar in the underhood fuse box, just check them all.
__________________
I cannot see through steel.
I cannot predict the future.
I cannot sh*t parts.

Reply With Quote
  #6  
Old 01-30-2009, 10:08 AM
Member
 
Join Date: Dec 2007
Location:
Posts: 58
Thanks: 0
Thanked 1 Time in 1 Post
Default RE: FAULT CODE P1647

ok i checked everything in above post. and nothing still throwing the same code. Whats the most logical next step without sending the car to the dealer. Change the oxegen sensor completly? please advise


thanks
Reply With Quote
  #7  
Old 10-12-2010, 08:11 PM
Junior Member
 
Join Date: Sep 2010
Location: Miami Fl
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just had the O2 sensor replace it was code 1647 which shows to be bank 2 but the code is still there.. What else could be going on
Reply With Quote
  #8  
Old 11-17-2011, 03:04 AM
Member
 
Join Date: Jun 2010
Location: Sweden
Posts: 30
Thanks: 0
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by 4470nautilus View Post
I just had the O2 sensor replace it was code 1647 which shows to be bank 2 but the code is still there.. What else could be going on
Hi

How was this resolved in the end?
Reply With Quote
Old 11-17-2011, 03:04 AM
 
 
 
Reply



Tags
1998, code, codes, engine, fault, fix, ii, jaguar, obd, p1647, trouble, type, xj6, xj8, xtype



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 07:03 AM.

Copyright © 2010 Internet Brands, Inc. All rights reserved.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014 vBulletin Solutions, Inc. All rights reserved.
JAGUAR and its logo are the registered trademarks of Jaguar Cars Limited. Jaguar Cars Limited is not affiliated with JaguarForums.com.