Go Back   Jaguar Forums - Jaguar Enthusiasts Forum > Jaguar Models ( Modern ) > X-Type
Sign in using an external account
Register Forgot Password?
Search

X-Type 2001 - 2009

Welcome to Jaguar Forums!
Welcome to JaguarForums.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Jaguar Forums community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-14-2010, 03:18 PM
Junior Member
 
Join Date: Oct 2010
Location: foxboro
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default spedometer not working warning lights on

I have a friend with a 2002 jaguar x type 2.5 a couple of weeks ago he was driving and all of a sudden the odometer, speedometer stopped working and also the check engine and abs light came on.. would anyone have any idea what this might be.
Reply With Quote
  #2  
Old 10-14-2010, 03:25 PM
Veteran Member
 
Join Date: Nov 2009
Location: Langley, BC
Posts: 1,010
Thanked 51 Times in 47 Posts
Default

Mine did the exact same thing after I got a gearbox fault. It was the transmissioin Control Module getting wet that caused all of it. But look up by the fuse box for moisture, if that stuff gets wet it throws every fault at you it can. Also get a blow drier, blow everything dry then reset the ODBII and see if that corrects everything. A tell tale sign with mine was putting the heater on full tilt and the windows were fogging. The carpets were dry by the way so it does not take much moisture, it has more to do with where the water goes.
__________________
Previously 2004 X-Type Sport Premium Estate, now Jagless.
Reply With Quote
  #3  
Old 10-14-2010, 04:53 PM
Thermo's Avatar
Veteran member
 
Join Date: May 2008
Location: Great Mills, MD
Posts: 8,014
Thanks: 0
Thanked 1,618 Times in 1,395 Posts
Default

George, I was thinking the same thing with the water on the tranny computer. The only other thing possibly is the connector to the computer is coming loose and is causing intermittent contact with the wiring to be made.
__________________
Chris "Thermo" Coleman and K'Re Ann, the 03 X
Reply With Quote
  #4  
Old 10-14-2010, 09:43 PM
Junior Member
 
Join Date: Oct 2010
Location: foxboro
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thank you very much for the info, if anyone else has come across this problem any information would greatly be appreciated. Thanks again guys.

George
Reply With Quote
Old 10-14-2010, 09:43 PM
 
 
 
Reply



Tags
02, 2002, broken, fix, intermittent, jag, jaguar, lights, malfunction, odometer, spedometer, speedometer, stopped, type, working, xtype



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 03:04 AM.

Copyright © 2010 Internet Brands, Inc. All rights reserved.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014 vBulletin Solutions, Inc. All rights reserved.
JAGUAR and its logo are the registered trademarks of Jaguar Cars Limited. Jaguar Cars Limited is not affiliated with JaguarForums.com.