O2 Sensor Bank 2 Sensor 1 - Where is it? - Jaguar Forums - Jaguar Enthusiasts Forum


X-Type ( X400 ) 2001 - 2009
Sponsored by Jagbits
Click Here

O2 Sensor Bank 2 Sensor 1 - Where is it?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2009, 01:51 PM
Member
Thread Starter
 
Join Date: Dec 2008
Location:
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Default O2 Sensor Bank 2 Sensor 1 - Where is it?

Related to my other post, just wanted to verify the location of this sensor with all of you knowledgeable about such things.

I was told by the dealer is was driver side, upstream = bank 2 sensor 1

Is this correct?

Thanks!
Reply With Quote
  #2  
Old 07-22-2009, 08:53 PM
Thermo's Avatar
Veteran member
 
Join Date: May 2008
Location: Great Mills, MD
Posts: 10,095
Thanks: 0
Thanked 2,357 Times in 2,026 Posts
Default

slipp3h, the "drivers side" of the engine is the side of the engine nearest the radiator. Remember, the engine sits sideways in the car, so the flywheel is near the driver's side wheel, not inline with the firewall.

As for sensor #1, that is the upstream sensor. Sensor #2 is the one downstream of the cat. So, in your case, you will need to open the hood. From there, remove the intake tubing going to the engine. Now remove the bottom half of the air filter box. If you look where the air filter box was, you will see the exhaust manifold there. You will see the O2 sensor right there. That is the one you need to replace.

if you need help with getting the O2 sensor out, let me know.
Reply With Quote
  #3  
Old 07-24-2009, 02:49 PM
Member
Thread Starter
 
Join Date: Dec 2008
Location:
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the help thermo. I ended up taking it to a jaguar speciality shop, if I had some free time coming up I'd do it myself, but for only $80 in labor it wasn't too bad. Even they weren't 100% positive of the location, so it helped to have you explain it and confirm what the dealer said.
Reply With Quote
  #4  
Old 01-03-2015, 11:54 PM
Junior Member
 
Join Date: Jan 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My 1995 jaguar xj vp. Is cranking but takes at least4-5second of holding key to start i replaced the fuel filter,crank sensor and new wires,checked the converters please if anyone knows what to try, help!
Reply With Quote
  #5  
Old 01-04-2015, 01:50 PM
Photobucket
 
Join Date: Sep 2010
Location: Miami
Posts: 361
Thanked 201 Times in 96 Posts
Default

Just a quick guide I made since this gets asked a lot

jaghelp.com: X-type heater oxygen sensor codes: P0031, P0032, P0037, P0038, P0051, P0052, P0057, P0058, P0131, P0132, P0133, P0137, P0138, P0140, P0151, P0152, P0153, P0157, P0158, P0160, P1646 and P1647
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Parkbrake fault, C1885, C1893 magmedia XJ XJ6 / XJ8 / XJR ( X350 & X358 ) 16 11-17-2015 12:47 PM
Transmission slippage Poet XK8 / XKR ( X100 ) 6 10-02-2015 10:00 AM
abs sensor disconnect Dave1109971 XJS ( X27 ) 3 10-01-2015 12:04 AM
Roadworthy Inspection after almost two years off the road Woznaldo XJ6 & XJ12 Series I, II & III 9 09-26-2015 12:02 PM
How I changed O2 sensors in a 2001 XKR Poet XK8 / XKR ( X100 ) 1 09-25-2015 01:32 PM


Tags
02, bad, bank, downstrean, drivers, jaguar, located, o2, sensor, sensors, side, xj6, xjr, xk8, xkr


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:01 PM.


JAGUAR and its logo are the registered trademarks of Jaguar Cars Limited. Jaguar Cars Limited is not affiliated with JaguarForums.com.