XJ XJ6 / XJR6 ( X300 ) 1995-1997

97 xj6 4.0 crank no start no spark

 
  #1  
Old 02-15-2019, 05:12 PM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default 97 xj6 4.0 crank no start no spark

My first post. Please soneone help me having issues with a 97 xj6 4.0 i bought yesterday. Was a no start from the door but i got it for 300 bucks so i didnt really care what it is. I charged up the battery and cranked it and it actually ran very rough for about 2 mins . I then scanned it and got code p1775. i seem to be intermittently getting no spark and hav replaced the crank sensor so far. I hate throwin parts at shitt for no reason but i was sure that was the issue. Now i get no starts at all and no spark. I am getting cranking rpms on the dash and the new crank sensor is ohm in spec. Although i am only getting 2.7 volts at the ckp sensor circuit. Could this be a bad ecm?! I already swapped relays . Please somebody point me in the right direction.
 
  #2  
Old 02-15-2019, 10:12 PM
Lady Penelope's Avatar
Veteran Member
Join Date: Apr 2017
Location: Kansas City USA
Posts: 3,776
Received 1,214 Likes on 966 Posts
Default


Watch the volt meter that it does not drop below 11.4 volts during starter rotation

Below this voltage the starter will rotate the engine but be below the voltage to properly run the ECU / spark

The instrument gauge is very accurate

There are 2 relays that power up different sections of the ECU , on is the small one on the corner of the RH engine fuse box you can swap with the LH engine fuse box ( LH is really just the horn relay )

The second large relay is the ECU controlled relay called the X that is enabled by the ECU to bring power back into the other section of the ECU

To bypass the CKPS and ECU control of the # 1 fuel pump relay you can jumper

 

Last edited by Lady Penelope; 02-16-2019 at 04:39 PM. Reason: point the starter will rotate the engine
  #3  
Old 02-16-2019, 06:21 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you for your reply. I know that i have proper cranking voltage because i have a very powerful jump box . Also where is this 2nd relay for the ecu . I have already swapped the one relay with the horn relay. Also i have 12 volts at the cam sensor. Not the crank tho?
 
  #4  
Old 02-16-2019, 08:32 AM
Lady Penelope's Avatar
Veteran Member
Join Date: Apr 2017
Location: Kansas City USA
Posts: 3,776
Received 1,214 Likes on 966 Posts
Default

See page 50 then back to 49 for the wring out page on the CKPS

Black 23 and Black 26 does not get a reference voltage from the ECU

http://www.jagrepair.com/images/Auto.../jagxj1997.pdf

As you saw your fundimental reading on the inductance CKPS is 1300 ohms , the funtional reading is a sine wave with a frequency dependent on RPM

The Camshaft position sensor ( CMPS )s a 3 wire hall effect sensor that by design is not needed to start engine

It has a basic power source and not a reference voltage source

My computer was going nuts last night so let me clean up the last nights post while shoveling driveway



 

Last edited by Lady Penelope; 02-16-2019 at 09:54 AM.
  #5  
Old 02-16-2019, 08:36 AM
Junior Member
Thread Starter
Join Date: Feb 2019
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you i will try . And all data gave me a crappy version of this. Also i had no idea the main beam was an ecm relay ����*♂️ Smh. And is ecm failure common woth these ?
 
  #6  
Old 02-16-2019, 03:46 PM
Lady Penelope's Avatar
Veteran Member
Join Date: Apr 2017
Location: Kansas City USA
Posts: 3,776
Received 1,214 Likes on 966 Posts
Default

Main beam and fog relays are swapping options

The most common problem with the X300 is my laptop
 

Last edited by Lady Penelope; 02-16-2019 at 04:01 PM.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
B-rad
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
18
04-10-2018 07:12 PM
jaguarlars
XJ40 ( XJ81 )
4
03-07-2014 11:50 AM
JagLoverX2
XJ XJ8 / XJR ( X308 )
4
11-27-2011 03:52 PM
bigdreams05
XJ6 & XJ12 Series I, II & III
0
07-17-2007 12:25 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 97 xj6 4.0 crank no start no spark


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: