XJ XJ8 / XJR ( X308 ) 1997 - 2003

No power to radio

 
  #1  
Old 06-25-2019, 07:44 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Cleveland UK
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default No power to radio

I have an aftermarket radio/sat nav fitted to my 1999 x308. I have suddenly lost power to the radio. I have checked the fuses behind the lhs rear footboard and they are all ok ( tested with multimeter)
The constant feed to the radio is dead but the 12v acc to the radio is working.
The dead lead is green/brown and had been working up until earlier this week.

Any ideas?? Relays etc & does the green brown lead run directly to the lhs rear fuse box.

Thanks
 
  #2  
Old 06-25-2019, 10:30 PM
Highhorse's Avatar
Veteran Member
Join Date: Feb 2013
Location: Trying to escape Central Florida
Posts: 2,827
Received 1,029 Likes on 797 Posts
Default

Welcome Mark, we would appreciate it if you would introduce yourself and your Jag here (site requirement)... https://www.jaguarforums.com/forum/n...-intro-must-5/

To start with, you'll want to bookmark this site,.. JagRepair.com - Jaguar Repair Information Resource ..it'll come in handy for numerous scenarios. It was put together by a site member with a culmination of solved issues, TSB's and such to include what I'm about to link you to.

Here is the pdf electrical guide for your car.... http://www.jagrepair.com/images/Auto.../jagxj1998.pdf

How are you running your system? If you have one, is it running through the old Amp/Nav setup? ...or are you powering directly. If directly, pull up that pdf and start tracing your power. If through the old Amp/Nav, it could be that.
 
  #3  
Old 06-26-2019, 04:04 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Cleveland UK
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Not running through the old system, I dont have power to the fuse beneath the rear LH seat I need to find where that power source originates.
 
  #4  
Old 06-26-2019, 05:48 AM
Highhorse's Avatar
Veteran Member
Join Date: Feb 2013
Location: Trying to escape Central Florida
Posts: 2,827
Received 1,029 Likes on 797 Posts
Default

Read the pdf
 
  #5  
Old 06-26-2019, 09:41 AM
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Cleveland UK
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default

Sorted it, I just ran a new wire from the fuse box with an additional in line fuse.

Thanks all
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
gotmoss89
S-Type / S type R Supercharged V8 ( X200 )
13
06-23-2012 06:26 AM
gotmoss89
S-Type / S type R Supercharged V8 ( X200 )
11
04-23-2011 02:16 AM
kdross
XK8 / XKR ( X100 )
3
04-17-2010 11:11 PM
fidget247
XJ XJ8 / XJR ( X308 )
2
04-06-2010 06:43 PM
LarryK
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
1
01-26-2010 01:01 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: No power to radio


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: