XJ6 & XJ12 Series I, II & III 1968-1992

RPM drop to zero

 
  #1  
Old 10-24-2014, 08:22 PM
ottotto's Avatar
Junior Member
Thread Starter
Join Date: Oct 2014
Location: Vancouver
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default RPM drop to zero

Hi,
got my 1974 XJ12 a few weeks ago and the engine was working fine so far. Today I started cold and had it run for a few minutes. After warming up all of a sudden the RPM dropped to zero. Restarted a few times and the RPM went up to about 2000 RPm and dropped again to zero, without any stuttering or similar.

To be clear: the engine stops running, so it's not only the RPM gauge is dropping to zero.

Any idea what that might be? Probably no fuel supply?

Would be great if someone had a similar problem and got it fixed.

Thanks
Eric
 
  #2  
Old 10-25-2014, 07:31 PM
Veteran Member
Join Date: Apr 2012
Location: New York City
Posts: 1,705
Received 857 Likes on 554 Posts
Default

Lets start with a fuel pressure guage. If you dont have one then pick one up at your local autozone and post the fuel pressure.
 
  #3  
Old 10-26-2014, 09:40 AM
ottotto's Avatar
Junior Member
Thread Starter
Join Date: Oct 2014
Location: Vancouver
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by icsamerica View Post
Lets start with a fuel pressure guage. If you dont have one then pick one up at your local autozone and post the fuel pressure.
Thanks, will try today and let you know if it cured my problem.
Eric
 
  #4  
Old 10-26-2014, 10:28 AM
Veteran Member
Join Date: Jul 2012
Location: Walnut Creek, California
Posts: 5,732
Received 1,945 Likes on 1,569 Posts
Default

It would be odd indeed if the engine stopped running and the tach displayed numbers!!


But, as the tach relies on ignition pulses, it is a very good clue. Ignition issue!!!
Whatever device is making and breaking isn't doing it. Points and condensor or electronic.


Carl
 
  #5  
Old 10-27-2014, 08:49 AM
ottotto's Avatar
Junior Member
Thread Starter
Join Date: Oct 2014
Location: Vancouver
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by JagCad View Post
It would be odd indeed if the engine stopped running and the tach displayed numbers!!


But, as the tach relies on ignition pulses, it is a very good clue. Ignition issue!!!
Whatever device is making and breaking isn't doing it. Points and condensor or electronic.


Carl
Hi,
The former owner seemed to battle cables and wiring and I think focusing on wiring and the ignition part is also necessary. Wanted to avoid this part for later on but since there is no problem with fuel pressure the ignition might be the issue.
Thanks
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dave1109971
XJS ( X27 )
52
12-15-2015 06:16 PM
tomkilner
XJ XJ6 / XJR6 ( X300 )
16
10-09-2015 07:10 AM
inactualis
XJ XJ8 / XJR ( X308 )
7
10-02-2015 11:13 AM
baskervillema
XJ XJ6 / XJR6 ( X300 )
4
10-01-2015 06:43 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: RPM drop to zero


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: