XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

1993 XJS 4.0 Low-Speed Stumbling/Misfire

 
  #1  
Old 07-09-2019, 01:41 PM
Junior Member
Thread Starter
Join Date: May 2019
Location: California
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default 1993 XJS 4.0 Low-Speed Stumbling/Misfire

I've had my 5-speed manual 'box 4.0 XJS a few months now. It has 125M on it. It passed California smog no problem. No check engine lights. Starts perfectly, idles smoothly. But driving along at low speeds (such as in a parking lot or small surface streets) at a consistent speed, it appears to have a misfire and slight stumbling, enough to make progress slightly jerky. Passengers don't notice it but I do. Same cold or hot. It accelerates smoothly, and I do not notice this at high speeds. I've run injector cleaner through a tank of gas, and replaced the spark plugs (not the coil-topped type). No difference. Any input?

Thanks,
~ Dave
 
  #2  
Old 07-11-2019, 06:17 AM
JigJag's Avatar
Veteran Member
Join Date: Mar 2016
Location: North Carolina
Posts: 1,273
Received 503 Likes on 328 Posts
Default

Given no injection harness quality concerns, I think it’s worth having a professional injector cleaning service clean your injectors and return you a balanced set.

At larger throttle openings the injector is remaining open longer. Any variation in the opening and closing speed of the injector becomes less and less of a factor in the total amount of fuel delivered as a larger percentage of its time ( milliseconds ) is spent at full flow. At idle, any variation here is a much large factor.

‘But I like starting cheep and easy and working my way up to expensive and difficult only if necessary. A full can of Seafoam in 10 gallons of fuel. Burn it up. Repeat several times. Once ain’t gonna do it.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Rhett
XJ6 & XJ12 Series I, II & III
9
11-17-2017 05:17 PM
lannygray
X-Type ( X400 )
2
08-20-2013 10:23 AM
TN8Shooter
XJ XJ8 / XJR ( X308 )
14
10-22-2010 09:35 PM
ricasso
XJ XJ8 / XJR ( X308 )
6
06-27-2010 01:23 PM
05kingranchfx4
X-Type ( X400 )
6
08-01-2008 07:38 AM

Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 

Thread Tools
Search this Thread
Quick Reply: 1993 XJS 4.0 Low-Speed Stumbling/Misfire


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: