XJ XJ6 / XJR6 ( X300 ) 1995-1997

Unstable at high speed

 
  #41  
Old 11-30-2018, 11:37 AM
Tcasmarcus's Avatar
Senior Member
Thread Starter
Join Date: Sep 2016
Location: Hamar, Norway
Posts: 301
Received 58 Likes on 48 Posts
Default

Here is an update and a new piece in the puzzle.
After having changed all the front suspension parts all shocks, bushes and the nylon spacer for the rack the car felt massively improved to drive. Far more stable and no nasty thumps in the steering wheel.

But there was still an issue with the rear end.
It felt unstable and just plain weird. I also started getting some uneven wear on right rear tire.

I purchased new rear bearings and Included the taper roller bearings. Decided to let my local mechanic do the job and it wasn't an easy task as it had rusted solid. The taper roller bearings were just completely dry and stuck. Rusted and impossible to move in any way. The garage spent half a day fixing it but it now feels 100%. Way more stable and just better to drive.

I actually think I'm quite pleased with the car at the moment


 
The following users liked this post:
Doug (11-30-2018)
  #42  
Old 05-02-2019, 12:55 PM
Tcasmarcus's Avatar
Senior Member
Thread Starter
Join Date: Sep 2016
Location: Hamar, Norway
Posts: 301
Received 58 Likes on 48 Posts
Default

Guess what.. I was still not happy with the feeling of an unstable car. after the winter i put on the summer tires again and it felt horrible. tramlining and the steering was not going where i wanted it to go. so i finally decided to buy an overhauled steering rack from Germany. cost me an arm and a leg..

i really hope that will be the final solution.
will install it by the end of next week so i might be able to confirm this soon hopefully.

any words of advice from you guys that i can pass on to my mechanic?
 
  #43  
Old 05-15-2019, 11:05 AM
Tcasmarcus's Avatar
Senior Member
Thread Starter
Join Date: Sep 2016
Location: Hamar, Norway
Posts: 301
Received 58 Likes on 48 Posts
Default

new rack installed and initial reaction was just oh my god it feels so light to steer. like i never had servo before. Feels also very precise so i think all is good now. some tramlining though due to worn front tires so will get new ones.
 
  #44  
Old 05-24-2019, 01:24 PM
Tcasmarcus's Avatar
Senior Member
Thread Starter
Join Date: Sep 2016
Location: Hamar, Norway
Posts: 301
Received 58 Likes on 48 Posts
Default

new tires on. its steady and just perfect to drive now. this issue is solved!
 
The following 4 users liked this post by Tcasmarcus:
Doug (05-24-2019), littlelic69 (05-27-2019), Scotlad (05-24-2019), Sheff928 (05-25-2019)
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: