XJ6 & XJ12 Series I, II & III 1968-1992

speedo bounces while cranking

 
  #1  
Old 11-12-2014, 04:31 PM
Senior Member
Thread Starter
Join Date: Nov 2012
Location: lewis county,wa
Posts: 107
Received 6 Likes on 5 Posts
Default speedo bounces while cranking

Here's the problem this time. While cranking, the speedometer goes up to 50 mph and bounces around. Tach doesn't move at all. Mind you this is just while cranking. I recently swapped out the steering column, maybe I messed something up?
 
  #2  
Old 11-12-2014, 04:51 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,160
Received 6,562 Likes on 4,864 Posts
Default

Classic case of voltage drop. On many cars the speedo does a dance when voltage is low.

Check the usual places for a loose/dirty connection. Don't forget to check the "+" junction posts on the firewall

Cheers
DD
 
The following users liked this post:
Jag7651 (11-13-2014)
  #3  
Old 11-12-2014, 07:16 PM
Senior Member
Thread Starter
Join Date: Nov 2012
Location: lewis county,wa
Posts: 107
Received 6 Likes on 5 Posts
Default

Interesting, I just went around and cleaned/tightened all the grounds and firewall posts... guess I'll recheck everything. Thanks
 
  #4  
Old 11-12-2014, 08:16 PM
Senior Member
Join Date: Apr 2013
Posts: 167
Received 34 Likes on 30 Posts
Default

Mine doesnt only bounce but the mileage goes up with it, i will be pulling the dash soon as my voltage meter has a bent needle and i picked up a complete dash for $34[very happy]
 
  #5  
Old 12-03-2014, 07:44 AM
JagLoverT's Avatar
Member
Join Date: Oct 2011
Location: Indiana
Posts: 39
Received 3 Likes on 3 Posts
Default

I recently encountered the speedo and miles incrementing when trying to troubleshoot a no start condition on my '85 XJ6. On a cold day I started my Jag and it was running normal and I wanted to check my heater and heated rear window switch I installed last spring. The blower motors fired up (little noisy at first) and the rear window heat switch was on, then the engine started dieing and would not restart. I turned heater and rear window defroster switch off and attempted restart to no avail - acts like no fuel (waiting for warmer day to follow Dougs Fuel Pump Circuit Checklist), but I noticed the speedo was bouncing and the miles were incrementing, thought it was due to an electrical relay issue somewhere in the car that was causing some backfeed in wiring system. I disconnected the battery (thought it might reset relays) and left it disconnected for 2 hours and when I reconnected it the speedo bouncing and mileage incrementing stopped but the car still didn't start. Just thought I would share.
 
  #6  
Old 12-03-2014, 12:55 PM
Senior Member
Thread Starter
Join Date: Nov 2012
Location: lewis county,wa
Posts: 107
Received 6 Likes on 5 Posts
Default

The car hasn't moved for a year or 2. The battery has been disconnected and on a float charger this whole time.. I Still haven't gotten around to checking all the grounds yet
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PhilXJ6
XJ6 & XJ12 Series I, II & III
3
01-03-2016 08:55 PM
rocket1lf
S-Type / S type R Supercharged V8 ( X200 )
0
09-29-2015 09:16 AM
dieseldoc
XK8 / XKR ( X100 )
9
09-28-2015 01:17 PM
BSM
MKI / MKII S type 240 340 & Daimler
0
09-25-2015 05:00 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: speedo bounces while cranking


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: