XK / XKR ( X150 ) 2006 - 2014

Problem starting

 
  #1  
Old 04-27-2019, 12:15 PM
Senior Member
Thread Starter
Join Date: Mar 2019
Location: Los Angeles
Posts: 101
Received 15 Likes on 11 Posts
Default Problem starting

Good morning board. I experienced a starting problem this morning. I started her up and noticed it was idling weird, like it wasnít at a steady idle, wanted to die. It did twice... started and died. I left it alone for 2 minutes and then started right up. I have a 2009 XK 4.2L naturally aspired with 18k miles. All original, spark plugs, fluids with the exception of timely oil changes and a K & N air filter. Any ideas?
 
  #2  
Old 04-27-2019, 02:29 PM
Cee Jay's Avatar
Veteran Member
Join Date: Apr 2013
Location: Kaysville, Utah, US
Posts: 5,408
Received 1,142 Likes on 852 Posts
Default

It's dying of lethargy. The dang thing needs to RUN! 18,000 miles on a 2009??? WHY??!!?? What a waste of such a wonderful vehicle.
 
The following 2 users liked this post by Cee Jay:
badicedog (04-29-2019), riverman (04-28-2019)
  #3  
Old 04-27-2019, 02:37 PM
Senior Member
Thread Starter
Join Date: Mar 2019
Location: Los Angeles
Posts: 101
Received 15 Likes on 11 Posts
Default

[QUOTE=Cee Jay;2061666]It's dying of lethargy. The dang thing needs to RUN! 18,000 miles on a 2009??? WHY??!!?? What a waste of such a wonderful vehicle.[/QUOT

lol... I recently bought it from a Retiree. It had 14k miles on it. Itís a daily driver, believe me.
 
The following users liked this post:
Cee Jay (04-27-2019)
  #4  
Old 04-29-2019, 09:07 AM
110reef's Avatar
Senior Member
Join Date: May 2017
Location: Baton Rouge, LA
Posts: 642
Received 183 Likes on 132 Posts
Default

Mine has done that a time or two. No explanation for you. I just say, Hmmm and go about my business.

I've also had times where I start it up and the power steering seems to not work. Stop and start the car, and it works again.
 
The following users liked this post:
badicedog (04-29-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
GabrielG
XJ XJ6 / XJR6 ( X300 )
1
09-28-2014 09:15 PM
Prentice Aubrey
US Southwest
0
03-07-2013 06:46 PM
coolxj8
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
7
07-29-2007 12:29 PM
XJ XJ8 / XJR ( X308 )
4
02-25-2007 05:57 AM
XJ40 ( XJ81 )
1
09-20-2005 04:55 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Problem starting


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: