Cruise not Available, brake booster not performing. - Jaguar Forums - Jaguar Enthusiasts Forum

Go Back  Jaguar Forums - Jaguar Enthusiasts Forum > Jaguar Models ( Modern ) > X-Type ( X400 )
Reload this Page >

Cruise not Available, brake booster not performing.

Notices
X-Type ( X400 ) 2001 - 2009
Sponsored by:
Sponsored by:

Cruise not Available, brake booster not performing.

  #1  
Old 12-24-2018, 08:04 PM
BudL1te's Avatar
Junior Member
Thread Starter
Join Date: Mar 2018
Location: Arizona
Posts: 26
Thanked 1 Time in 1 Post
Default Cruise not Available, brake booster not performing.

Hello, I know this is fairly common with the cruise not available warning. I replace the PCV, I replaced the brake booster hose even though it didn't look bad. It seemed to run okay during the warmer months, but as soon as it dipped down below 60 degrees, I started getting Cruise not available everyday. It comes and goes.

with this, when the engine is cold, it feels like the brake booster is not getting enough vacuum. The brakes are very hard to press. Once the engine warms up, the brakes seem to do fine.

my dilemma, is the possibility that the brake booster could have a bad diaphragm, and when the engine bay heats up it will operate.

I have read the other posts about the O-rings, and also about gaskets for both sides of the intake the bottom part, and the top part. Obviously I don't want to have to dig in and replace these if it's not necessary. I am wondering if anyone else has had the same issue and needed to replace the brake booster itself, or if I replace the O-rings and the gaskets for the intake would that be the best thing to do?
 
  #2  
Old 12-24-2018, 08:06 PM
BudL1te's Avatar
Junior Member
Thread Starter
Join Date: Mar 2018
Location: Arizona
Posts: 26
Thanked 1 Time in 1 Post
Default

2002 xtype
 
  #3  
Old 12-26-2018, 04:51 PM
Senior Member
Join Date: May 2006
Location: connecticut
Posts: 736
Thanked 116 Times in 94 Posts
Default

simple hole in the hose
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MAX83
XF and XFR ( X250 )
0
04-07-2018 06:51 AM
o2manyfish
XK8 / XKR ( X100 )
11
06-02-2016 11:55 PM
dude1579
Jaguar Forums Feedback & Suggestion Center
2
09-17-2015 08:20 PM
bracester
X-Type ( X400 )
10
02-28-2013 03:57 PM
Jon89
S-Type / S type R Supercharged V8 ( X200 )
2
09-11-2010 04:01 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Cruise not Available, brake booster not performing.


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: