spedometer not working warning lights on - Jaguar Forums - Jaguar Enthusiasts Forum

Go Back  Jaguar Forums - Jaguar Enthusiasts Forum > Jaguar Models ( Modern ) > X-Type ( X400 )
Reload this Page >

spedometer not working warning lights on

Notices
X-Type ( X400 ) 2001 - 2009
Sponsored by:
Sponsored by:

spedometer not working warning lights on

Reply

 
 
 
  #1  
Old 10-14-2010, 03:18 PM
Junior Member
Thread Starter
Join Date: Oct 2010
Location: foxboro
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default spedometer not working warning lights on

I have a friend with a 2002 jaguar x type 2.5 a couple of weeks ago he was driving and all of a sudden the odometer, speedometer stopped working and also the check engine and abs light came on.. would anyone have any idea what this might be.
 
Reply With Quote
  #2  
Old 10-14-2010, 03:25 PM
Veteran Member
Join Date: Nov 2009
Location: Langley, BC
Posts: 1,010
Thanked 53 Times in 48 Posts
Default

Mine did the exact same thing after I got a gearbox fault. It was the transmissioin Control Module getting wet that caused all of it. But look up by the fuse box for moisture, if that stuff gets wet it throws every fault at you it can. Also get a blow drier, blow everything dry then reset the ODBII and see if that corrects everything. A tell tale sign with mine was putting the heater on full tilt and the windows were fogging. The carpets were dry by the way so it does not take much moisture, it has more to do with where the water goes.
 
Reply With Quote
  #3  
Old 10-14-2010, 04:53 PM
Thermo's Avatar
Veteran member
Join Date: May 2008
Location: Great Mills, MD
Posts: 11,238
Thanks: 0
Thanked 2,661 Times in 2,270 Posts
Default

George, I was thinking the same thing with the water on the tranny computer. The only other thing possibly is the connector to the computer is coming loose and is causing intermittent contact with the wiring to be made.
 
Reply With Quote
  #4  
Old 10-14-2010, 09:43 PM
Junior Member
Thread Starter
Join Date: Oct 2010
Location: foxboro
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thank you very much for the info, if anyone else has come across this problem any information would greatly be appreciated. Thanks again guys.

George
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
X_Type_South_Africa
X-Type ( X400 )
6
12-09-2015 05:37 PM
johnnie ryall
PRIVATE For Sale / Trade or Buy Classifieds
6
10-19-2015 09:44 PM
tberry6686
XK8 / XKR ( X100 )
3
09-20-2015 03:22 PM
Oliver9218
XJ XJ8 / XJR ( X308 )
3
09-03-2015 05:33 PM
Aranon
S-Type / S type R Supercharged V8 ( X200 )
3
09-01-2015 01:00 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: