XJ XJ6 / XJR6 ( X300 ) 1995-1997

Hellooooooooo

 
  #1  
Old 05-14-2019, 03:24 AM
Junior Member
Thread Starter
Join Date: May 2019
Location: Nigeria
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Hellooooooooo

I own a Jaguar xjexecutive ,1996 model....it refuses to start,after researching I discovered the 'body processor unit is bad'......I'm having difficulties searching for the right one with the number: LNA2500BB/002...i'm ready to make a purchase but I haven't found one....please if anyone has one or knows how I can get one here's my instagram handle :billy_turner1002
 
  #2  
Old 05-14-2019, 04:04 AM
GGG's Avatar
GGG
GGG is offline
Join Date: Dec 2011
Location: Durham, UK
Posts: 108,915
Received 10,259 Likes on 8,434 Posts
Default

Welcome to the forums oghene ejiro,

Check ebay UK - there are a few LNA2500BB Body Processor Modules listed.

I recommend you add details of why you have concluded the BPM is at fault. Members with the same model may be able to suggest other possible reasons for the non start.

Graham
 
The following users liked this post:
Don B (05-14-2019)
  #3  
Old 05-17-2019, 01:44 AM
SleekJag12's Avatar
Veteran Member
Join Date: Dec 2012
Location: Scottsdale, Arizona, USA
Posts: 1,101
Received 318 Likes on 248 Posts
Default

We need to know if it will not crank, or will not fire up and run. If no crank, then one of the simplest things to check is that the red "P" is lit up on the shift indicator. If not, the starter will not crank. Also try Neutral to see if it cranks.
 
  #4  
Old 05-17-2019, 11:39 AM
Junior Member
Thread Starter
Join Date: May 2019
Location: Nigeria
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default My x300

Hellooooooo,my car won't start,won't crank,the red light indicator on my j shifter comes up,I have tried putting it on neutral same thing,all my lights and entertainment system works....I don't know what to do next,I saw a video of an x300 on youtube,that shows similar problem,the body processor unit was replaced,and the car was ok....but my xj body processor unit number is rare to find....i haven't seen any......'LNA2500BB/002'.....
 
  #5  
Old 05-17-2019, 12:27 PM
Senior Member
Join Date: Feb 2012
Location: Manchester UK
Posts: 742
Received 520 Likes on 324 Posts
Default

Here's a couple of very simple tests you can do that will help eliminate some possible issues that can cause a No Crank.

1. Engine Ground. Use a jump lead to connect a good solid engine part to a good solid body earth point. If the car then cranks you know you have an issue with the earth strap (on engine down near starter motor)

2. Starter Relay. The starter Relay is in a group of 4 near the LH Headlamps. Swap the starter relay with one of the others (e.g. Fast Wiper Relay). The relays are identified in the Electrical Guides that can be download from the "How to Quick Links" section here

http://www.mediafire.com/?sharekey=c...2b492bd5edc68e

Also, check that the engine Management Light is on when you try to start the car.


If you have a multi meter and some basic electrical knowledge there are more tests that we can suggest to identify the cause of the problem before buying a new part.
 

Last edited by b1mcp; 05-17-2019 at 03:12 PM. Reason: Spelling
The following users liked this post:
Don B (05-17-2019)
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: