XJ6 & XJ12 Series I, II & III 1968-1992

87 xj6 floods and stalls

 
  #2  
Old 02-24-2009, 12:08 AM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,151
Received 6,557 Likes on 4,863 Posts
Default

Originally Posted by Efrain Arizpe View Post
My 87 xj6 has 34000 miles, it starts of running fine and then will start to flood and stall. Help

Most likely a coolant temp sensor for the fuel injection. Here's some more info:

http://www.jag-lovers.org/xjlovers/xjfaq/efirich.html


This assume you have a 1987 Ser III XJ6 with a 4.2. If you have a 1987 "XJ40" XJ6 with a 2.9 or 3.6 engine the details are different....as its a different car....but the fundmental ideas apply

Cheers
DD
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JaguarSV8
New Member Area - Intro a MUST
9
10-01-2015 01:58 AM
dansxj6
XJ6 & XJ12 Series I, II & III
2
09-28-2015 08:02 AM
42Ajd
PRIVATE For Sale / Trade or Buy Classifieds
0
09-26-2015 07:04 PM
BSM
MKI / MKII S type 240 340 & Daimler
0
09-25-2015 05:00 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 87 xj6 floods and stalls


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: