XJ6 & XJ12 Series I, II & III 1968-1992

Climate control problems

 
  #1  
Old 01-05-2012, 10:43 PM
Member
Thread Starter
Join Date: Mar 2011
Location: San Luis Obispo
Posts: 73
Received 5 Likes on 5 Posts
Default Climate control problems

I keep blowing fuses when running the climate control. When I got into it the heater was blowing hot only. I found that the windshield been leaking and the there was some rust on a flap that kept the flap from moving that opens the center vent. I got that unstuck and it was working good and then it started to blow the fuse for the fan. There is also a fuse that on the right side that goes to the thermal sensor that also is blowing. Does anyone have a idea what is going on?
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
XJsc-guy
PRIVATE For Sale / Trade or Buy Classifieds
6
09-25-2015 11:09 AM
tberg
XK / XKR ( X150 )
15
09-07-2015 07:32 AM
mcdutch
XK / XKR ( X150 )
4
09-04-2015 03:38 AM
obwoodie
New Member Area - Intro a MUST
8
09-03-2015 07:45 PM
laserguy
X-Type ( X400 )
3
09-03-2015 02:02 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Climate control problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: