XJ6 & XJ12 Series I, II & III 1968-1992

Fan Issues

 
  #1  
Old 12-30-2011, 08:41 PM
Junior Member
Thread Starter
Join Date: Dec 2010
Location: Canada
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default Fan Issues

I have a 1985 xj6 and the fan to blow the heat works sometimes. It's very frustrating, I will have a few weeks where it will work and of course it quit tonight when we had freezing rain.
The last time the fan stopped, it was fine the next day. Sometimes wiggling the key in the ignition helps.
My mechanic has been too busy to get me in and I am getting frustrated and upset as I need the car to get to work.
What might be wrong?
 
  #2  
Old 12-30-2011, 09:11 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,147
Received 6,547 Likes on 4,859 Posts
Default

Loose/dirty/worn/corroded connections are often the culprit in these cases.

The climate control system has four fuses. Often the fuse clips, and/or the steel end caps of the fuses, are corroded.

Check/clean all fuses in the left and right fuse boxes (only two are for the cliamte control but might as well do them all at once) as well as the hidden climate control fuse behind the console right side "cheek panel". It's on brown/yellow wires and is clipped to the right side of the main case of the the climate control system.

There is also another fuse for the cliamate control amplifier hidden behind the console left cheek panel.

There are other possibilities but the fuses are an easy place to start.

The ignition switch often wears out, causing various problems...but usually engine stalling is one of them. Anyhow, the switch is easily replaced. It mounts on the back of the ignition lock.

Cheers
DD
 
  #3  
Old 12-31-2011, 06:16 AM
Junior Member
Thread Starter
Join Date: Dec 2010
Location: Canada
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you Doug I will try and see if that's the issue. Going back to work today to get my car. Hoping the windshield can be cleared of the ice and not fog up so I can get home with it.
 
  #4  
Old 01-05-2012, 06:47 PM
Junior Member
Thread Starter
Join Date: Dec 2010
Location: Canada
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default New Update

Well, here is the update for the car, I took it to the mechanic and he said the climate control module is not working.

He wants over $1000 to replace it. He said it takes a lot of time to remove the dash. I paid $1500 for labour on all 4 brakes and rotors to be replaced with a mechanic (but he is extremely undependable) and this mechanic I am unsure about now comparing prices.

Any thoughts on this?? I feel the price is way too high.
 
  #5  
Old 01-05-2012, 07:23 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,147
Received 6,547 Likes on 4,859 Posts
Default

Module? Not sure what he means.

Perhaps he's referring to the amplifier. It's the (sorta) soild-state brains of the operation. About $200-$300 for the part. Actual labor time to install would be maybe 30 minutes.....as most people leave the old one in place and just let the new one sit alongside. He's entitled to charge for his troublshooting....which in itself may have run into a fair bit of time.

Still, though, I wonder if we're even on the same page with respect to what he wants to replace.

Cheers
DD
 
  #6  
Old 01-06-2012, 06:05 AM
Junior Member
Thread Starter
Join Date: Dec 2010
Location: Canada
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

He said its the control where you select the fan temperature the dial on the dash by the radio he said the entire dash has to come out to replace and that's what he's wanting to charge $1000 plus to do. That's not troubleshooting price that job price but he says he doesn't want to do it. He instead sending a wire off and putting a dial control for fan speed on the console beside where my knee would be to bypass the issue.
The $1000 and removal of the entire dash didn't sound right and not at that price.
 
  #7  
Old 01-06-2012, 07:17 AM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,147
Received 6,547 Likes on 4,859 Posts
Default

Originally Posted by Jennell View Post
He said its the control where you select the fan temperature the dial on the dash by the radio he said the entire dash has to come out to replace and that's what he's wanting to charge $1000 plus to do. That's not troubleshooting price that job price but he says he doesn't want to do it. He instead sending a wire off and putting a dial control for fan speed on the console beside where my knee would be to bypass the issue.
The $1000 and removal of the entire dash didn't sound right and not at that price.


Ok, those controls on either side of the radio ARE difficult to replace. Once I though I might have to replace one of them and did some checking... and determined it would be several hours labor.

Not sure about "entire dash" removal....I think it was more like "entire console" removal...but it's a labor intensive job no matter how you slice it.

Cheers
DD
 
  #8  
Old 01-07-2012, 06:35 AM
Junior Member
Thread Starter
Join Date: Dec 2010
Location: Canada
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

Once he got working on added a switch to control the heat, he looked at the area in question and said only a part of a panel has to come out and this is about 3 hours labour. He apologized for giving the high price of $1000 and saying the whole dash had to come out.
If I hadn't told him what you posted in reply Doug, I think he would have tried to get that amount from me. New mechanic for me. So thank you very much for the advise!
 
  #9  
Old 01-07-2012, 06:26 PM
Junior Member
Thread Starter
Join Date: Dec 2010
Location: Canada
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default

Well first day of using the car, driving back home. When I shut the car off the blower wouldn't shut off. Fan shut off but the heat kept coming through. Had to disconnect the battery for now.
 
  #10  
Old 01-31-2012, 04:21 PM
Junior Member
Join Date: Jan 2012
Location: BC Canada
Posts: 9
Received 0 Likes on 0 Posts
Default

I am having the same issues with my Blower motor(s) work one day next do not work and when working only have at best low fan and what I can determine only one motor working. I am a mechanic but have never worked on Jags. I bought this one off a customer for $400 and have systematically rewired almost every circuit/relay (do you think jag could use any more relays or fuses???) probably got 50+ hours into it. I am thinking that the actual control unit (above radio in console) is the culprit because nothing works at all in the automatic setting only on Manual. Does anyone have wiring diagrams and or some more advice where I should start. If it is the resistor (or whatever jag calls it) shouldnt the fan(s) still work on high (full 12V) at least??? My VCM does not indicate any fuse problems but I am in the process of traking them down and cleaning (good thing my shop is slow) Man I feel so inadequate. Any help would be much appreciated.
 
  #11  
Old 01-31-2012, 04:23 PM
Junior Member
Join Date: Jan 2012
Location: BC Canada
Posts: 9
Received 0 Likes on 0 Posts
Default

Sorry forgot to mention it is a 1991 XJ6
 
  #12  
Old 01-31-2012, 06:54 PM
Join Date: Jan 2012
Location: Newport Beach, California
Posts: 3,600
Received 1,147 Likes on 926 Posts
Default Fan Issues

Originally Posted by WhyDidIBuyaJag View Post
Sorry forgot to mention it is a 1991 XJ6
Unless you have a Series III XJ12, which was sold in your country until 1992, you should probably ask for assistance in the XJ40 forum.

NBCat
 
  #13  
Old 02-01-2012, 12:39 PM
Junior Member
Join Date: Jan 2012
Location: BC Canada
Posts: 9
Received 0 Likes on 0 Posts
Default

Thanx I will
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
99xk8guy
XK8 / XKR ( X100 )
21
06-28-2019 06:32 PM
JarodL
F-Type ( X152 )
53
04-23-2019 09:04 PM
DrTripp
New Member Area - Intro a MUST
10
09-14-2015 07:58 PM
1100me
XJS ( X27 )
2
09-07-2015 06:26 AM
mbergen
XJS ( X27 )
6
09-04-2015 08:36 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Fan Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: