XJ6 & XJ12 Series I, II & III 1968-1992

Radiator non-standard?

 
  #1  
Old 06-19-2019, 05:58 AM
Andy T.'s Avatar
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Khon Kaen, Thailand
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Radiator non-standard?

I have recently bought a Series 3 XJ6 4.2 here in Thailand. It is right hand drive (as suits this country). The car was bought as a non-runner and some of the cooling hoses are missing or possibly incorrectly connected.

On all pictures from manuals, parts books and internet searches I can find, the expansion tank has the two small hoses that exit the front top of the expansion tank running forward towards the radiator. One connects to the pipe which then runs across the front bulkhead and into the manifold. The other to a union at the top of the radiator.

On my car, the radiator does not have a union on the left hand side, but there is one on the right! This union was not connected to anything, and there was no hose connected to one of the small expansion tank unions.

I am assuming that I need to make up some pipework to connect these together, which should logically give me an equivalent circuit to the standard. I would appreciate comments from forum users if you think this is right. Has anyone any idea why my radiator might be different to standard? Perhaps it is a replacement from the original and is from a different model which is otherwise the same as the normal XJ6? Any suggestions would be welcome.



In the picture above, I think the hose is connected to the wrong union on the expansion tank. I think it should be the RHS union that connects to the pipe that runs across the front bulkhead.



Union on right hand side of radiator that I think needs to be connected back to the expansion tank (LHS unon on tank).

Second question on the hoses I think I have worked out but will ask as well: there is a hose running from the water pump which is connected to the union exiting the bottom of the manifold about halfway along. I think this is wrong and that it should run to the throttle body, then another pipe out of the throttle body and into the manifold. Can aynone confirm?
 
  #2  
Old 06-19-2019, 10:30 AM
Jose's Avatar
Veteran Member
Join Date: Mar 2007
Location: Florida
Posts: 5,826
Received 1,338 Likes on 1,088 Posts
Default

Hi,

in my 1984 XJ-6, the left hose from the expansion tank goes down into the left side of the radiator, through the plastic shroud.

the right hose from the expansion tank connects to a steel line through the bulkhead, which then comes out on the opposite side where another hose connects to the steel line and then to the intake manifold.
 
  #3  
Old 06-20-2019, 01:17 AM
Andy T.'s Avatar
Junior Member
Thread Starter
Join Date: Jun 2019
Location: Khon Kaen, Thailand
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for the confirmation about which of the two small hoses from the expansion tank connect to what. It would appear that my radiator is different to standard, so I think all I need to do is run a hose to the union on the right hand side to make the equivalent connection to normal layout.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
slmskrs
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
13
02-10-2019 09:50 AM
Gerard Radimaker
S-Type / S type R Supercharged V8 ( X200 )
6
07-04-2018 10:21 AM
hoopics
F-Pace (X761) / C-X17
8
04-05-2018 08:39 AM
worrasf
XK8 / XKR ( X100 )
5
05-02-2016 09:30 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Radiator non-standard?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: