XJ6 & XJ12 Series I, II & III 1968-1992

Will not idle properly

 
  #1  
Old 09-03-2016, 12:34 PM
Member
Thread Starter
Join Date: Apr 2016
Location: Lafayette, Louisiana
Posts: 97
Likes: 0
Received 2 Likes on 2 Posts
Default Will not idle properly

I have a 1981 Xj6 and just found the temperature sensor and it ran pretty good for a day .Now it won't idle properly. It idles about 400 rpm and wants to die. I can increase the rpm and it runs fine. I tried to adjust the idle screw but it has no effect on the idle. Any ideas??? Thanks Jerry
 

Last edited by albjerryg; 09-03-2016 at 12:46 PM. Reason: Spelling
  #2  
Old 09-03-2016, 06:28 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,149
Received 6,550 Likes on 4,861 Posts
Default

Originally Posted by albjerryg View Post
. It idles about 400 rpm and wants to die. I can increase the rpm and it runs fine.
A couple easy places to jump off from:

Make sure the ducting between the AFM and the throttle body is secure and leak free

Also, clean the throttle body and make sure the throttle blade is set at .002" gap. Fussy to adjust, if needed, but it has to be done

I tried to adjust the idle screw but it has no effect on the idle. Any ideas??? Thanks Jerry
To clarify, you were using the idle speed adjuster on the air distribution block, yes? This is the small aluminum casting a couple inches forward of the throttle body with some hose attached.

The adjuster screw actually just varies the amount of air being admitted into the engine besides what the .002" throttle blade gap allows. It's a controlled leak, in a manner of speaking. If turning it makes no difference then the passageway might be gunked up (remove the distribution block for a good cleaning) or there is another, larger air leak somewhere else (such as the ducting, above) that is bigger than the 'leak' provided by the adjuster screw...thus making the adjuster screw ineffective.

Cheers
DD
 
  #3  
Old 09-03-2016, 07:38 PM
Member
Thread Starter
Join Date: Apr 2016
Location: Lafayette, Louisiana
Posts: 97
Likes: 0
Received 2 Likes on 2 Posts
Default Will not idle properly

I had checked before and made sure the bellows was on properly. Yes the Aluminum block below the AFM with the allen screw had no effect on the idl I turned it all the way in and all the way out nothing. Should I remove it and try to clean it out??? Thanks Jerry
 
  #4  
Old 09-03-2016, 07:51 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,149
Received 6,550 Likes on 4,861 Posts
Default

Originally Posted by albjerryg View Post
Should I remove it and try to clean it out??? Thanks Jerry

Yup!

Cheers
DD
 
  #5  
Old 09-03-2016, 07:54 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,149
Received 6,550 Likes on 4,861 Posts
Default

When you remove the air distribution block the 'over run valve' will come out with it. The over run valve looks somewhat like a thermostat. Anyhow, pay attention which way the valve fits so you can put it back the same way! This has caused confusion over the years. I myself can't remember after all these years. Some the of Jaguar literature apparently shows it upside down...so the manuals can't be relied upon in this case.

Cheers
DD
 
  #6  
Old 09-03-2016, 08:00 PM
Member
Thread Starter
Join Date: Apr 2016
Location: Lafayette, Louisiana
Posts: 97
Likes: 0
Received 2 Likes on 2 Posts
Default Will not idle properly

Ok sound good I will try to get to it tomorrow. Again Thanks Jerry
 
  #7  
Old 09-05-2016, 06:54 AM
Member
Thread Starter
Join Date: Apr 2016
Location: Lafayette, Louisiana
Posts: 97
Likes: 0
Received 2 Likes on 2 Posts
Default Will not idle properly

I took out the idle body ad cleaned it up good , I didn't remove the over-run valve and put it all back and ran the car and was able to adjust the idle better but not perfect. I have ordered a rebuilt AFM and waiting for it to come in and try that? I will let you know when the AAFM come in . Tanks Jerry
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
William Falkenklev
XJ XJ8 / XJR ( X308 )
49
06-04-2016 07:03 PM
JigJag
XJ6 & XJ12 Series I, II & III
1
04-29-2016 11:41 AM
80sRule
XK8 / XKR ( X100 )
6
04-19-2016 11:53 AM
S-Type / S type R Supercharged V8 ( X200 )
2
02-08-2013 09:05 PM
XJ6 & XJ12 Series I, II & III
1
11-29-2005 10:55 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Will not idle properly


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: