XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

Oh bugger.....

 
  #1  
Old 06-19-2014, 06:10 PM
malc4d's Avatar
Veteran Member
Thread Starter
Join Date: May 2013
Location: Orlando
Posts: 1,292
Received 326 Likes on 297 Posts
Default Oh bugger.....

So, today l fitted the pollen filters.....Why l hear you say, its a convertible......Hmm, l must say that half way through, that thought popped into my head too. Its not so easy on my '92 facelift, the plug for the wipers is in the way. It doesn't look pretty but they're in.
ANYWAY....now my washers just dribble......Dammmm whats wrong...do l need to prime and if so how ????
(forgot to say that they were left unplugged for 5 weeks as l was sent the wrong filters..) and no, the pipes are not pinched.....




bugger bugger bugger
 

Last edited by malc4d; 06-19-2014 at 10:00 PM.
  #2  
Old 06-19-2014, 06:34 PM
Vee
Vee is online now
Veteran Member
Join Date: May 2010
Location: Arlington, VA
Posts: 2,749
Received 613 Likes on 510 Posts
Default

Sounds like you could have pinched one of the water lines feeding the sprayers when you installed the pollen filters.

Maybe it's not pretty AND not window washer friendly...
 
  #3  
Old 06-21-2014, 06:42 AM
malc4d's Avatar
Veteran Member
Thread Starter
Join Date: May 2013
Location: Orlando
Posts: 1,292
Received 326 Likes on 297 Posts
Default

Anyone ?????
 
  #4  
Old 07-18-2014, 07:42 AM
malc4d's Avatar
Veteran Member
Thread Starter
Join Date: May 2013
Location: Orlando
Posts: 1,292
Received 326 Likes on 297 Posts
Default

Hi guys ..Still only got a dribble coming out of the screen washer.....any help ??
They worked fine until l unplugged them.
 
  #5  
Old 07-18-2014, 07:46 AM
Steve M's Avatar
Veteran Member
Join Date: Jul 2012
Location: Wiltshire, UK
Posts: 3,866
Received 1,236 Likes on 934 Posts
Default

It is possible that you disturbed a bit of crud which has made it's way up to the jets and partially blocked them; can you back blow the whole thing with a compressed air gun?
 
  #6  
Old 07-18-2014, 07:48 AM
jimbov8's Avatar
Veteran Member
Join Date: Jul 2012
Location: Uk
Posts: 1,986
Received 594 Likes on 534 Posts
Default

Malc,
Unplug them again and switch them on. If you still have a dribble then, unplug from the bottle and blow some air through it.

Once you have proved the pipe is clear then you will have to check the bottle itself. Could be gunged at the bottom and may need cleaning.

This is one of those trial and error jobs, work through methodically and you will get there.

Hope this helps,
 
  #7  
Old 07-19-2014, 08:50 AM
malc4d's Avatar
Veteran Member
Thread Starter
Join Date: May 2013
Location: Orlando
Posts: 1,292
Received 326 Likes on 297 Posts
Default

Thanks guys. Will try again this weekend.
 
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: