XK120 XK140 XK150 1948 - 1962

Problem with WEBER 32/36 DGAV

 
  #1  
Old 05-17-2018, 10:21 AM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Problem with WEBER 32/36 DGAV

Hello!
I have a problem with twin weber 32/36 DGAV. I have a Jaguar MK IX 3.7 l and two weber carburetors. After cleaning carburetors, when I have more then 2000 RPM my engine lose power. I do not know where is the problem. When I have slow turns engine is working propertly, when I give him a little gas the is a problem. What I should check?
 
  #2  
Old 05-18-2018, 02:26 PM
Junior Member
Thread Starter
Join Date: May 2018
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

Problem solved. Auxiliary Venturi was wrong side.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Curt Lee
XJ6 & XJ12 Series I, II & III
2
01-18-2016 06:45 PM
SteveJM
MKI / MKII S type 240 340 & Daimler
2
03-25-2015 02:30 PM
krswen
E type ( XK-E )
0
07-31-2014 01:53 PM
krswen
E type ( XK-E )
0
11-13-2013 02:56 PM
M90power
XJS ( X27 )
10
06-09-2012 01:29 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Problem with WEBER 32/36 DGAV


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: