XK120 won't go into reverse - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
XK120 XK140 XK150 1948 - 1962

XK120 won't go into reverse

Reply

 
 
 
  #1  
Old 06-10-2018, 01:24 PM
Junior Member
Thread Starter
Join Date: Mar 2015
Location: palo alto
Posts: 16
Thanked 0 Times in 0 Posts
Default XK120 won't go into reverse

After 20+ years of sitting idle my 120 will not engage reverse. Before pulling carpeting off top of trans. box thought I'd check and see if there are any ideas out there. I've idled the engine and slowly released the clutch with transmission lever in various positions neutral (center) and upper left position where reverse is located on shifting pattern. Always remains in a forward gear. I thought I might get rear end back up on jack stands and run through the gears with wheels rotating to see if a 5 minute run time buys me any change. The gear shaft appears to be in correct position for reverse all the way forward and to the left, but still a forward running position. Any thoughts anyone?
 
Reply With Quote
  #2  
Old 06-10-2018, 03:58 PM
George Camp's Avatar
Senior Member
Join Date: Jul 2014
Location: SC
Posts: 421
Thanks: 0
Thanked 126 Times in 101 Posts
Default

Geo tried to send you a private message--no joy--I think I have the answer--call the JCNA tech line --888 258 2524
 
Reply With Quote
  #3  
Old 06-13-2018, 11:10 PM
Junior Member
Thread Starter
Join Date: Mar 2015
Location: palo alto
Posts: 16
Thanked 0 Times in 0 Posts
Default

george camp thank you for your advice. Reverse problem has been taken care of. When I heard the Kachunk and the loud audio response I knew that I was in reverse. Backed out of the garage (first time in 24 years). Brakes still a problem. Still feels like there must be air in the system. Will get the presssure bleeder back and have another go at it. Someone mentioned that I might have additional play in the "Master Linkage" not sure if that refers to the slack in the Master Cylinder linkage. At any rate, might try a dedicated oil pump with Dot 4 and a hose filling the wheel cylinders up front pumping fluid down and have the bleeder valve open. My brother said the old Chyrslers had a problem with air and trying to bleed down instead of bleeders on top. Will follow through with solution
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
James Sagkos
X-Type ( X400 )
3
11-08-2017 04:56 PM
cdre
XK8 / XKR ( X100 )
3
07-24-2017 05:33 PM
Lude
X-Type ( X400 )
7
06-02-2011 10:45 AM
SleekCat
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
11
04-30-2011 07:44 PM
xj8vdp
XJ XJ8 / XJR ( X308 )
12
05-12-2010 04:50 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: