Go Back  Jaguar Forums - Jaguar Enthusiasts Forum > General Jaguar Forums > Regional > US Northeast
Reload this Page >

NJ - Comprehensive Component Not Ready

Notices
US Northeast ME, NH, VT, MA, RI, CT, NJ, NY, PA

NJ - Comprehensive Component Not Ready

 
  #1  
Old 08-29-2014, 07:27 AM
Senior Member
Thread Starter
Join Date: Jul 2014
Posts: 283
Thanked 33 Times in 23 Posts
Default NJ - Comprehensive Component Not Ready

Hello.

I posted this in the XKR Forum, but thought it might be more appropriate here. 2003 XKR.

Can anyone tell me what "Comprehensive Component" is for NJ State Inspection? The local guy in town said this will never "reset" on it's own and that my computer has been tampered with?

So I am failing for Comprehensive Component "Not Ready" and Overall Readiness Result "FAIL"

The person I purchased from in FL said an O2 sensor was replaced recently.

I called Cherry Hill Jag, they said drive with fuel between 25% and 75% but I see on my NJ Inspection that Evap was ready?

I am new to Jag, frankly all this twisting and turning over one setting and failing inspection is giving me 2nd thoughts.

Any input from NJ Jaguar XKR/XK8 that have seen this, is greatly appreciated.

Regards,
 
Attached Thumbnails NJ - Comprehensive Component Not Ready-inspection.jpg  

Last edited by R3Wood; 08-29-2014 at 07:32 AM. Reason: typo addition
  #2  
Old 08-29-2014, 07:42 AM
WhiteXKR's Avatar
Veteran Member
Join Date: Apr 2010
Location: Arlington VA USA
Posts: 7,465
Thanked 2,696 Times in 2,003 Posts
Default

It will take patience, but I believe if you continue driving it will flip to ready on its own. Comprehensive is normally the last test to complete.

This thread discusses how to apply for a tailpipe test in NJ as an alternative if necessary: Failed NJ inspection 3x now, Comprehensive Component Not Ready - North American Motoring
 
The Following User Says Thank You to WhiteXKR For This Useful Post:
R3Wood (08-29-2014)
  #3  
Old 08-30-2014, 07:59 AM
Senior Member
Thread Starter
Join Date: Jul 2014
Posts: 283
Thanked 33 Times in 23 Posts
Unhappy

Thanks. The local garage here told me it will never go to ready on it's own.

Any idea why it's "NOT READY?"

I think the battery may have been disconnected or died recently (maybe in late July) and O2 sensor bank 2, which was replaced, code cleared. No other codes present.

I also read Mini's have this issue.

Does anyone know for sure if the Comprehensive Component line will eventually switch to "READY" on it's own?

What is the worst part is the car is not a polluter and it still does not pass.

Thanks,
 
  #4  
Old 08-30-2014, 08:03 AM
WhiteXKR's Avatar
Veteran Member
Join Date: Apr 2010
Location: Arlington VA USA
Posts: 7,465
Thanked 2,696 Times in 2,003 Posts
Default

When the codes are cleared all monitors go to not ready and the process starts anew.

In my own XKR the last two to clear were EVAP and comprehensive, and they cleared separately. Virginia will pass you with one not ready monitor and I passed with comprehensive still not ready. Subsequently, after some more miles comprehensive passed (my OBDII reader gives the status of the monitors, so I was able to see for myself).

Unless your garage has hands-on experience with your exact car and model year and this problem, I would take his pronouncement with a grain of salt.
 

Last edited by WhiteXKR; 08-30-2014 at 08:09 AM.
The Following User Says Thank You to WhiteXKR For This Useful Post:
R3Wood (08-31-2014)
  #5  
Old 08-31-2014, 07:53 AM
Senior Member
Thread Starter
Join Date: Jul 2014
Posts: 283
Thanked 33 Times in 23 Posts
Default

Originally Posted by WhiteXKR View Post
When the codes are cleared all monitors go to not ready and the process starts anew.

In my own XKR the last two to clear were EVAP and comprehensive, and they cleared separately. Virginia will pass you with one not ready monitor and I passed with comprehensive still not ready. Subsequently, after some more miles comprehensive passed (my OBDII reader gives the status of the monitors, so I was able to see for myself).

Unless your garage has hands-on experience with your exact car and model year and this problem, I would take his pronouncement with a grain of salt.
Thanks! I appreciate the information, especially being new to Jaguar and the XKR. I love driving this car and it would be a shame if it all cracked due to NJ State Inspection.
 
  #6  
Old 04-16-2015, 11:25 AM
Senior Member
Thread Starter
Join Date: Jul 2014
Posts: 283
Thanked 33 Times in 23 Posts
Default

Well no sticker yet. I parked the car in October and it has been in the heated garage since then. In January the battery stopped taking the CTek charge and we had snow, cold etc. On Monday I put a new battery in, it fired right up, brought the tire pressure up to spec and went out for a nice drive. Now the question is, since the battery was dead and the car was brought back to life on 4/13/15, how long before I venture to the inspection station? It drives me crazy driving without the sticker and probably just a matter of time before I am hassled.
 

Last edited by R3Wood; 04-16-2015 at 11:29 AM.
  #7  
Old 04-22-2015, 01:19 PM
StypeRowner's Avatar
Senior Member
Join Date: Aug 2009
Location: Egg Harbor Twp.,NJ,USA
Posts: 258
Thanked 22 Times in 21 Posts
Default Stress relief

Take it to a major auto parts store where they'll read your OBD for free.
I'd call ahead to make sure they provide this free service.

Good Luck!!!

 
The Following User Says Thank You to StypeRowner For This Useful Post:
R3Wood (05-05-2015)
  #8  
Old 01-14-2016, 04:38 PM
Junior Member
Join Date: Jan 2016
Location: Jersey
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Default

There is an easy fix for this. Here is the procedure to follow to get the comprehensive component monitor ready:

http://obdclearinghouse.com/index.ph...t_file&id=1418
 
Attached Files
The Following User Says Thank You to NJCarGuy For This Useful Post:
Jumpin' Jag Flash (01-16-2016)
  #9  
Old 01-16-2016, 07:12 AM
Senior Member
Join Date: Jan 2012
Location: Toms River, NJ
Posts: 565
Thanked 60 Times in 50 Posts
Default

I have had the same problem for over a year now, MIL on and showing a P0456. I know this code is a small leak in the EVAP system, I do get a smell of gas outside of the car right after fill up if I drive under 15 miles, after that no smell and never any smell in the cabin.

I disconnected the battery in hopes of clearing a PARKING BRAKE FAULT message which it did and the MIL has been off for 600 miles now and my OBD reader shows no codes but does show EVAP not ready.

I am sure my car has gone through the above drive cycle many times but the EVAP will not complete. Any thoughts?

I have been driving with a failed sticker all this time too.
 
  #10  
Old 04-05-2016, 05:50 PM
Member
Join Date: Apr 2015
Location: Harleysville, PA
Posts: 62
Thanked 19 Times in 15 Posts
Default

Originally Posted by Clamdigger View Post
I have had the same problem for over a year now, MIL on and showing a P0456. I know this code is a small leak in the EVAP system, I do get a smell of gas outside of the car right after fill up if I drive under 15 miles, after that no smell and never any smell in the cabin.

I disconnected the battery in hopes of clearing a PARKING BRAKE FAULT message which it did and the MIL has been off for 600 miles now and my OBD reader shows no codes but does show EVAP not ready.

I am sure my car has gone through the above drive cycle many times but the EVAP will not complete. Any thoughts?

I have been driving with a failed sticker all this time too.
Clamdigger, did you ever get EVAP to complete and what was secret?

 
  #11  
Old 04-06-2016, 07:39 AM
Senior Member
Join Date: Jan 2012
Location: Toms River, NJ
Posts: 565
Thanked 60 Times in 50 Posts
Default

Quantico I still have the same problem
 
  #12  
Old 08-30-2018, 08:55 AM
Senior Member
Thread Starter
Join Date: Jul 2014
Posts: 283
Thanked 33 Times in 23 Posts
Default

Sorry for waking this thread from the dead. I'm back in the same thing again. Fixed EVAP Leak, new battery, now i'm weeks in, and hundreds of miles and it's groundhog day, Comprehensive Component NOT READY. I find the Jaguar drive cycles to be a real joke. Recently on my Audi A6, I had manifold runners replaced in Turnersville (all codes reset) 40 min drive to Mays Landing inspection station it went right thru passed. Why is Jaguar Comprehensive Component such a mystery? So I carry the scan tool with me, check it when I get to work, then check it again when I get home, and check it yet again after pleasure miles on the weekend. I've put more miles on the car for Comprehensive Component than joy riding LOL.
 
  #13  
Old 03-14-2019, 05:03 AM
staggerlee51's Avatar
Member
Join Date: Sep 2014
Location: Ewing Township, NJ
Posts: 65
Thanked 1 Time in 1 Post
Default

Recently, was reunited with my love after a long separation due to major repairs. I had turned in the plates thinking that I would sell it as a project car or for parts. Ultimately, after a search for a replacement and no serious offers, I decided to repair the car. So, before picking up the car, I had to get new plates! With the plates installed, I was then anxious to take the car through NJDMV inspection. WHY DIDN’T SOMEONE TELL ME ABOUT THIS DRIVING CYCLE BUSINESS! Naturally, I failed for emissions readiness and was awarded the dreaded red “REJECTED” sticker. Driving around with this sticker on an otherwise beautifully operating and beautifully looking automobile makes one feel that everyone is looking at the sticker! Well, I decided to purchase an OBDII reader, so that I would know when all systems were ready! Again, foolishly, I cleared all codes and, after over a week of driving for systems to re-set, had to start from square one! (Perhaps, this along with the driving cycle requirements should be added to the “stickies”.) Now, all diagnostic monitors are ready except the CCM. I will drive the car up until the deadline for re-inspection...hopefully, the CCM monitor will have re-set! I HATE THOSE RED STICKERS!!!
 

Last edited by staggerlee51; 03-14-2019 at 05:05 AM. Reason: Remove emojis
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Johnken
XK8 / XKR ( X100 )
11
04-08-2018 10:21 AM
hoodun
XJS ( X27 )
26
10-06-2015 08:34 PM
Lawrence
XJ40 ( XJ81 )
3
10-01-2015 08:36 AM
Jaguar Forums Editor
Jaguar Press release
0
09-25-2015 11:58 AM

Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 

Thread Tools
Search this Thread
Quick Reply: NJ - Comprehensive Component Not Ready


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: