X-Type ( X400 ) 2001 - 2009
Sponsored by:
Sponsored by:

elm light new o2 sensors & exhaust !!

 
  #1  
Old 03-24-2019, 10:46 AM
Junior Member
Thread Starter
Join Date: Jan 2019
Location: south yorkshire
Posts: 11
Received 0 Likes on 0 Posts
Default elm light new o2 sensors & exhaust !!

2003 x type 2.1 v6 petrol in need of some help......eml light is on , car failed the mot, it's had new exhaust and x2 o2 sensors, eml is still on .
The sensors and leak in the exhaust was said to be the cause.
Will I need an OBDII tool to turn it off ??
 
  #2  
Old 03-24-2019, 11:15 AM
Join Date: Oct 2007
Location: PHX some of the time
Posts: 101,949
Received 4,759 Likes on 4,275 Posts
Default

No, you will need an OBD tool to read the codes so you identify and repair the fault.
Without the code that's triggering the light you won't get useful advise.
 
The following users liked this post:
Melb2018 (03-24-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Frog
XK8 / XKR ( X100 )
36
03-09-2019 09:41 PM
Cockbain
General Tech Help
3
07-17-2015 09:22 AM
2jag
General Tech Help
9
06-22-2012 09:16 PM
markman
XK8 / XKR ( X100 )
5
08-23-2011 05:11 PM
carlorner
S-Type / S type R Supercharged V8 ( X200 )
9
07-12-2011 01:48 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: elm light new o2 sensors & exhaust !!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: