XJ XJ6 / XJR6 ( X300 ) 1995-1997

Jag '96 VDP Driver low beam not illuminating

 
  #1  
Old 12-12-2018, 11:51 AM
Junior Member
Thread Starter
Join Date: Dec 2018
Location: USA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Question Jag '96 VDP Driver low beam not illuminating

Noticed flickering on low beam driver's side & installed new bulb...now not illuminating at all...all other lights function...did obvious like check ground/clean contacts at fuse box connections (there was some corrosion but cleaned)/fuses etc ... small pilot bulb illuminates in the driver's side lamp but not main bulb (bulb checks OK)...any suggestions or possibly an electrical schematic for that '96 VDP or XJ headlamp electrical system? Thanks very much
 
  #2  
Old 12-12-2018, 07:46 PM
Lady Penelope's Avatar
Veteran Member
Join Date: Apr 2017
Location: Kansas City USA
Posts: 3,775
Received 1,213 Likes on 965 Posts
Default


Last edited by Lady Penelope; 12-12-2018 at 08:01 PM.
  #3  
Old 12-13-2018, 01:02 AM
SleekJag12's Avatar
Veteran Member
Join Date: Dec 2012
Location: Scottsdale, Arizona, USA
Posts: 1,096
Received 318 Likes on 248 Posts
Default

In particular, Relay #2, LH side is the one to check ("dipped beam" is British terminology for low beam). Swap it with #1 (all those relays are the same). The relays unhook from the frame with wires attached. Keep in mind the relay itself is difficult to pop out as they are meant to be weatherproof. And they are dirty.
 
The following users liked this post:
Lady Penelope (12-13-2018)
  #4  
Old 12-13-2018, 03:25 AM
Lady Penelope's Avatar
Veteran Member
Join Date: Apr 2017
Location: Kansas City USA
Posts: 3,775
Received 1,213 Likes on 965 Posts
Default

Those British terms taunt me deeply

If you flip them upside down and spray them with penetrating oil and a rag to grip them it helps

I found some of the wires damaged under there for whatever reason
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hawaiiboyy
X-Type ( X400 )
2
04-13-2014 04:44 PM
cybercg
XJS ( X27 )
3
09-30-2013 03:43 PM
mlewisfwa
XK8 / XKR ( X100 )
5
05-13-2008 04:57 PM
X-Type ( X400 )
19
01-02-2007 04:37 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Jag '96 VDP Driver low beam not illuminating


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: