XJ XJ6 / XJR6 ( X300 ) 1995-1997

What did you do to your X300 today?

 
  #1  
Old 04-12-2015, 09:31 PM
al_roethlisberger's Avatar
Veteran Member
Thread Starter
Join Date: Mar 2014
Location: Sanford, NC
Posts: 3,735
Received 615 Likes on 467 Posts
Lightbulb What did you do to your X300 today?

Sometimes this type of thread can be inspiring, so I thought I'd start...

  • First, washed off the thick coat of yellow pine pollen
  • Vacuumed out the interior and trunk
  • Re-glued carpet to trunk spare tire cover
  • Brushed some rust from the lower radiator bracket, touched it up
  • Installed new front bumper undertray and plastic rivets
  • Installed new SC belt, idler and tensioner pulley

....meant to install an "Andy Bracket" but found someone had already beat me to it!


Last weekend repaired the "jewel" lenses in the front & rear fog light switches, rebuilt instrument cluster and added some alloy gauge trim rings.

.
 

Last edited by al_roethlisberger; 04-12-2015 at 09:37 PM.
  #2  
Old 04-13-2015, 01:42 AM
Senior Member
Join Date: Oct 2014
Location: Canada
Posts: 259
Received 39 Likes on 33 Posts
Default

Well some of the work i did lately on my XJR6 are...
  • Differencial Fluid Change
  • Parking Light Bulb Replacement
  • Supercharger Oil Change

Still need to change that god damn fuel filter, kind of failed last time lol but i'm gonna go down there again and try it next time.
also thinking of drain n fill the tranny since i do not know when it was last serviced.
 
  #3  
Old 04-13-2015, 05:07 AM
AL NZ's Avatar
Senior Member
Join Date: Feb 2013
Location: Napier, NZ
Posts: 890
Received 255 Likes on 180 Posts
Default

today? Monday here in NZ
Went to work, drove it like I stole it in short bursts on the way there.
Chugged home at a steady 60mph to see what economy I could get - got 25mpg (imperial) over a 10 mile trip.
I am just enjoying having my XJR back after 8 weeks in the shop.
Andy has been very helpful. The saga is complex, but I think the car is almost sorted, just enjoying it finally (owned for 5 days, then 8 weeks off the road).
The manual gearbox has noisy bearings but that is a job that will keep.
The front brakes shudder from high speed stops so may need a skim or new rotors.
Headlining can wait.
thinking of changing off the XJR sport 17" wheels for 18" Asteroids which I prefer.
 
  #4  
Old 04-13-2015, 05:25 AM
Join Date: Feb 2010
Location: Adelaide Stralia
Posts: 19,414
Received 5,735 Likes on 4,116 Posts
Default

Um, sold it.

Replaced it with the Black S Type, and the collector finally collected it.
 
  #5  
Old 04-13-2015, 07:19 AM
al_roethlisberger's Avatar
Veteran Member
Thread Starter
Join Date: Mar 2014
Location: Sanford, NC
Posts: 3,735
Received 615 Likes on 467 Posts
Default

Yeah, fuel filter change is on my list as well. I have it on the bench in a box, just need to get around to it.

That and SC oil also.


.
 
  #6  
Old 04-13-2015, 07:50 PM
Senior Member
Join Date: Aug 2013
Location: Toronto
Posts: 113
Received 24 Likes on 20 Posts
Default What did you do to your X300 today?

I don't know whether you'll believe me, but fitting two microphones beneath the car trying to find out why I have spanish castanets underneath on overrun.

At first thought it might be a very noisy Rochester Valve (can't imagine why) but I've checked everything else, changed center bearing looked hard at everything else. Just finished wiring in and now raining hard. Hope tomorrows better.
 
  #7  
Old 04-13-2015, 08:59 PM
aholbro1's Avatar
Veteran Member
Join Date: Aug 2010
Location: Decatur, TX
Posts: 4,413
Received 1,385 Likes on 952 Posts
Default

What is "overrun?"
 
  #8  
Old 04-13-2015, 10:16 PM
Member
Join Date: Jul 2014
Location: Georgia
Posts: 56
Likes: 0
Received 7 Likes on 6 Posts
Default

Al....what are alloy gauge trim rings?
 
  #9  
Old 04-14-2015, 11:24 AM
Senior Member
Join Date: Aug 2013
Location: Toronto
Posts: 113
Received 24 Likes on 20 Posts
Default What did you do to your X300 today?

What is "overrun?"

Sorry aholbro1, should be deceleration, foot off throttle pedal. Hope that helps.
Better day today. Will go out soon to try.
 
The following users liked this post:
aholbro1 (04-17-2015)
  #10  
Old 04-14-2015, 04:16 PM
al_roethlisberger's Avatar
Veteran Member
Thread Starter
Join Date: Mar 2014
Location: Sanford, NC
Posts: 3,735
Received 615 Likes on 467 Posts
Lightbulb Alloy Instrument or Gauge Trim Rings

Originally Posted by Compounder View Post
Al....what are alloy gauge trim rings?

Here you go:

https://www.jaguarforums.com/forum/x...-rings-140338/


.
 
  #11  
Old 04-15-2015, 04:02 PM
dagny747's Avatar
Senior Member
Join Date: Mar 2014
Location: boston
Posts: 292
Received 52 Likes on 40 Posts
Default New Wheels

I decided to go with another set of the original wheels after looking around at other styles. One set for the snows and one for the summer tires. the best deal I could find was at Rock Auto, $130/wheel. They are actually reconditioned, not new.
 
Attached Thumbnails What did you do to your X300 today?-new-jag-wheel.jpg  
  #12  
Old 04-15-2015, 09:53 PM
GatorJoe's Avatar
Senior Member
Join Date: Mar 2012
Location: Florida, USA
Posts: 390
Received 62 Likes on 50 Posts
Default

Dagny747, dimple wheels look good. Let us know if you're happy with the finish.
 
  #13  
Old 04-16-2015, 11:20 AM
al_roethlisberger's Avatar
Veteran Member
Thread Starter
Join Date: Mar 2014
Location: Sanford, NC
Posts: 3,735
Received 615 Likes on 467 Posts
Default

Seems like a good price. Wish I could find the XJR wheels refinished for that price, but they are just not common enough I guess. Mine aren't "bad" but it would be nice to get refreshed ones, or have mine done. ....perhaps one day

.
 
  #14  
Old 04-17-2015, 10:26 AM
dagny747's Avatar
Senior Member
Join Date: Mar 2014
Location: boston
Posts: 292
Received 52 Likes on 40 Posts
Default

Originally Posted by GatorJoe View Post
Dagny747, dimple wheels look good. Let us know if you're happy with the finish.
I am happy with the finish, its called bright silver and is definitely painted. So, its not the silver you would get if you refinished the wheels by polishing and then putting a clearcoat on it. That said, they are straight and look good, I believe the color is the same or similar to what you would buy if you got the wheel paint for BMW or Mercedes wheels. As you can see from the picture the back has the OEM PN on it.
 
Attached Thumbnails What did you do to your X300 today?-jag-wheel-pn.jpg  
The following users liked this post:
GatorJoe (04-19-2015)
  #15  
Old 04-17-2015, 12:11 PM
Senior Member
Join Date: Oct 2014
Location: Canada
Posts: 259
Received 39 Likes on 33 Posts
Default

**** i swear i have the weirdest problem lately. I bought a brand new remote from SNG Barrat last week because my old remote had broken buttons and super weak range. The car is like totally tripping out, when i put the car into learning mode it doesn't seem to pick up the new remote signal at all? and if i don't do anything it exits learning mode after 15 second so that would mean it would erase all previous remote ? but that was not the case... my broken remote would still work, and if i try to program the old remote in and it actually accepts it . WTF! and yes they are the same frequency which is 315mhz, im like so ****ing lost. any ideas? or is this a dealership visit to program with pdu?
 
  #16  
Old 04-18-2015, 01:44 PM
Senior Member
Join Date: Jan 2012
Posts: 228
Received 61 Likes on 55 Posts
Default

Today I got a four wheel alignment done. It was miles out!

Just have to wear the tyres straight again now.
 
  #17  
Old 04-18-2015, 05:54 PM
al_roethlisberger's Avatar
Veteran Member
Thread Starter
Join Date: Mar 2014
Location: Sanford, NC
Posts: 3,735
Received 615 Likes on 467 Posts
Thumbs up Fixed a little, found a little more to do....

Changed the spark plugs, installed correct Champion RC12YC, cleaned MAF.

Wire brushed off some rust from the coil and injector cover bolts and resprayed with some silver paint.

In the process I discovered that the third (counting from the front of the engine, not sure how Jag numbers the cylinders) spark plug well had a good amount of oil in it. So I guess replacing the valve cover gaskets is in order in the near future.

I also tore two of the paper coil gaskets (not the insulators) so will need to pick up a set of those. Need to find the part# for those gaskets I guess....

But overall a nice quick tune-up afternoon

.
 
The following users liked this post:
MikeyB10 (03-18-2016)
  #18  
Old 04-18-2015, 07:29 PM
Scarecrow's Avatar
Senior Member
Join Date: Jul 2014
Location: Miami
Posts: 164
Received 57 Likes on 32 Posts
Default

Changed the brake fluid. Going to clean and condition all the leather in the interior tomorrow.
 
  #19  
Old 04-25-2015, 09:39 PM
Junior Member
Join Date: Feb 2014
Location: Seattle
Posts: 9
Likes: 0
Received 1 Like on 1 Post
Default

Over the past month or so I've changed the water pump and thermostat, O2 sensor (bank 1 Sensor 2) removed the P0139 code and extinguished dreaded CEL, changed the EGR Valve, vacuumed the drove it to Portland OR and back to Seattle.

On my return trip from Ohio the first week of this April I was pleased to discover the speed limit in South Dakota had been raised from 75 to 80 mph.
 
  #20  
Old 04-25-2015, 10:10 PM
al_roethlisberger's Avatar
Veteran Member
Thread Starter
Join Date: Mar 2014
Location: Sanford, NC
Posts: 3,735
Received 615 Likes on 467 Posts
Default

Man, would love an 80MPH speed limit here, but at least most of my hour drive home is at 70MPH posted

.
 

Thread Tools
Search this Thread
Quick Reply: What did you do to your X300 today?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: