XJ6 & XJ12 Series I, II & III 1968-1992

Leaking A/C

 
  #1  
Old 07-06-2019, 05:08 PM
yachtmanbuttson's Avatar
Senior Member
Thread Starter
Join Date: Jun 2016
Location: Palm City, Florida
Posts: 597
Received 75 Likes on 52 Posts
Default Leaking A/C

So I completely rebuilt my A/C system short of what's under the dash. And it does blow cold and works great. However, I'm have a leaking problem as determined by an electronic sniffer I bought. It seems to be at the aft end of the A6 compressor. And... It seems to be at that little cylinder thingy at the top of the pic. It doesn't attach to anything electrical. It's just there. Anybody have any ideas?

it's the part on top with a brown paint chip off it.
 
  #2  
Old 07-06-2019, 06:34 PM
Senior Member
Join Date: Mar 2018
Location: Middlesex Cty, Massachusetts
Posts: 218
Received 49 Likes on 30 Posts
Default

I don't know what that is specifically, but I have an A6 currently in the garage and I just looked at it. That hole in the end has some kind of coil in it (within the cylinder) and it unbolts with a 15 mm wrench. I think it is the oil fill hole with some kind of pressure relief. In any case, what you really want to know is whether it can leak. When you unbolt that, there is definitely, 100%, an O-Ring there which I saw with my own eyes 10 minutes ago. If that is crusty, presumably a potential leak?
 
  #3  
Old 07-06-2019, 06:56 PM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,148
Received 6,550 Likes on 4,861 Posts
Default

I think your looking at the pressure relief valve which can be better seen in this pic, the brass thingy at the left 9 o'clock position




Cheers
DD
 
  #4  
Old 07-06-2019, 07:20 PM
yachtmanbuttson's Avatar
Senior Member
Thread Starter
Join Date: Jun 2016
Location: Palm City, Florida
Posts: 597
Received 75 Likes on 52 Posts
Default

Yes, I unscrewed it and replaced the o-ring before putting it back together. And the sniffer goes off when I put it right on the end so it's leaking out the end.
 
  #5  
Old 07-08-2019, 10:58 AM
yachtmanbuttson's Avatar
Senior Member
Thread Starter
Join Date: Jun 2016
Location: Palm City, Florida
Posts: 597
Received 75 Likes on 52 Posts
Default

I have a used A6 compressor and it has that pressure relief valve. I swapped it over yesterday, but didn't have any more R134A. So I bought two cans today and will vacuum and pressurize it tonight and see if that was the culprit.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
doriel
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
9
10-11-2016 08:02 PM
longo44
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
2
09-28-2007 08:35 PM
Humy
X-Type ( X400 )
2
09-18-2007 06:44 PM
X-Type ( X400 )
1
03-07-2007 01:09 PM
X-Type ( X400 )
3
10-02-2006 10:12 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Leaking A/C


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: