XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

speedo and trip computer issues ?

 
  #1  
Old 02-15-2014, 12:12 AM
Member
Thread Starter
Join Date: Aug 2013
Location: christchurch new zealand
Posts: 60
Received 4 Likes on 3 Posts
Default speedo and trip computer issues ?

Hi ,
1992 xjs le mans 5.3 3 speed auto .
all has been going well with the xjs but have come across a couple of small issues .
Every now and then when I start the car the trip computer seems to lose the plot and zeros itself including the time /clock display or will display time as 0000 or 8888 no biggie really just wondering if anyone may know why ?.
The other thing is the speedo ,seems to be ok up till about 140 160 k then after that will only read up to about 180 k , even when pulling about 5500 revs or more .Pretty sure speedo is ok up to at least 120 k as got pinged the other weekend for 120 k ,mister plod pulled me over and asked",Sir do you know what your speed was" I replied "about 120 k " "congratulations sir you must have one of the most accurate speedo's in NZ as that is the exact speed I clocked you at , and that seemed to be the limit of his sense of humor .
 
  #2  
Old 02-15-2014, 12:33 AM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,148
Received 6,547 Likes on 4,859 Posts
Default

Originally Posted by mlp442009 View Post
Hi ,
1992 xjs le mans 5.3 3 speed auto .
all has been going well with the xjs but have come across a couple of small issues .
Every now and then when I start the car the trip computer seems to lose the plot and zeros itself including the time /clock display or will display time as 0000 or 8888 no biggie really just wondering if anyone may know why ?.


Often as simple as excessive voltage drop due to poor connections. Remove the plug-in connector and re-seat it a couple times. Sometimes that alone will restore proper contact and all's well



Cheers
DD
 
The following users liked this post:
mlp442009 (02-15-2014)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dickc
XJS ( X27 )
5
09-08-2015 08:15 AM
carcycle
S-Type / S type R Supercharged V8 ( X200 )
5
09-07-2015 10:22 AM
AL NZ
XJ XJ6 / XJR6 ( X300 )
3
09-04-2015 08:39 PM
pocketrocket
New Member Area - Intro a MUST
9
09-03-2015 07:44 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: speedo and trip computer issues ?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: