XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

XJ-SC discovery...

 
  #1  
Old 06-03-2019, 10:17 AM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 8
Likes: 0
Received 3 Likes on 1 Post
Default XJ-SC discovery...

So I've been working slowly through maintenance and repair issues on the '88 xjsc I bought a month ago and posted a pic of. I've been driving the car regularly, and have a bit of a stumble/misfire at idle, and I would say performance is OK, but lackluster. I didn't know what I should expecting, though.
Yesterday, I started removing all of the obstacles to plug removal, including the capstan, cruise control, and A/C compressor.

After spending some time cleaning 31 years of crud out of the vee, I started looking into plugs, especially curious about whether the hard-to-get-to ones had been touched. I reached for the plug wire on the driver's side of the A/C compressor, and found the wire loose, and only resting on the tip of the plug. I thought "cool, a smoking gun for my miss..."

Then, I reached for the plug. It was so loose in the threads that it pretty much just fell out. It was possibly in contact with a thread or two. It had what looked like years of blow-by residue coating the sides of it.

I guess I have been driving a V11... Amazingly, it ran remarkably well. can't wait to try all 12.
 
The following 3 users liked this post by ChrisHarley2008:
Doug (06-05-2019), Grant Francis (06-05-2019), kjopen (06-05-2019)
  #2  
Old 06-05-2019, 07:59 AM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,009
Received 6,492 Likes on 4,821 Posts
Default

Yours is not a particularly unusual story. These engines will run 'fairly well' even with some rather glaring faults.

I am 100% sure that many of these old V12s are not running up to par and the owners don't even realize it. Dirty throttle bodies, worn and mis-adjusted throttles, inoperative vacuum and centrifugal advance systems, worn spark plugs....

Cheers
DD
 
The following users liked this post:
Grant Francis (06-05-2019)
  #3  
Old 06-06-2019, 05:39 AM
Crackerbuzz's Avatar
Senior Member
Join Date: Jul 2018
Posts: 257
Received 57 Likes on 48 Posts
Default

When I purchased my XJS I stumbled across my distributor cap completely cracked in half with one side half fallen off the dizzy base plate.

it still ran perfectly fine on all 12 pots.

i was flabbergasted and simply replaced it.

cant believe she ran ok like that
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kurtomatic
New Member Area - Intro a MUST
4
10-14-2012 06:37 AM
sogood
XJ XJ6 / XJR6 ( X300 )
3
01-19-2012 12:45 PM
MosDefXType
X-Type ( X400 )
0
10-24-2011 03:44 PM
Innovative Detailing
Detailing / Car care
1
09-07-2010 04:18 AM
SeismicGuy
XK8 / XKR ( X100 )
9
02-03-2009 10:05 PM

Currently Active Users Viewing This Thread: 4 (0 members and 4 guests)
 

Thread Tools
Search this Thread
Quick Reply: XJ-SC discovery...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: