Glove box light does not work even if lamp is ok - Jaguar Forums - Jaguar Enthusiasts Forum

Go Back  Jaguar Forums - Jaguar Enthusiasts Forum > Jaguar Models ( Modern ) > XK / XKR ( X150 )
Reload this Page >

Glove box light does not work even if lamp is ok

Notices
XK / XKR ( X150 ) 2006 - 2014

Glove box light does not work even if lamp is ok

Reply

 
 
 
  #1  
Old 06-12-2018, 03:37 PM
Macc's Avatar
Member
Thread Starter
Join Date: Apr 2017
Location: Finland
Posts: 97
Thanked 8 Times in 7 Posts
Default Glove box light does not work even if lamp is ok

Well, the title says it all. So...where is the fuse catering for this lamp (and possibly the 12V output)?
 
Reply With Quote
  #2  
Old 06-12-2018, 08:12 PM
Ranchero50's Avatar
Veteran Member
Join Date: Mar 2017
Location: Hagerstown MD
Posts: 2,401
Thanked 631 Times in 471 Posts
Default

Download the electrical schematics from the sticky at the top of the subforum and let us know what you find.
 
Reply With Quote
The Following User Says Thank You to Ranchero50 For This Useful Post:
Macc (06-13-2018)
  #3  
Old 06-13-2018, 02:55 PM
Macc's Avatar
Member
Thread Starter
Join Date: Apr 2017
Location: Finland
Posts: 97
Thanked 8 Times in 7 Posts
Default

Ok, have to that for future...but this time it was easier: I corrected the position of glove box and that side cover right from glove box, and magically two things happened: lamp started working and I was able to open the glove box fully. Now everything works! (except brakes squeak and sometimes feel like metal to metal screeching, but service next monday...)


Btw Ranchero50, I am still very grateful to you for those exhaust extra parts every time I do 1400rpm...definitely will buy you a lunch if I ever come there
 
Reply With Quote
The Following 2 Users Say Thank You to Macc For This Useful Post:
Cee Jay (06-13-2018), Ranchero50 (06-13-2018)
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BadKat174
XJS ( X27 )
13
09-17-2015 12:15 AM
supra-raleigh
XJ40 ( XJ81 )
2
10-13-2014 03:47 PM
al_roethlisberger
XJ XJ6 / XJR6 ( X300 )
11
06-14-2014 08:42 AM
pt80chip
X-Type ( X400 )
12
10-24-2013 07:54 PM
Lcgi
X-Type ( X400 )
8
07-14-2011 09:18 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: