XK8 / XKR ( X100 ) 1996 - 2006

misfires today - RESOLVED

 
  #1  
Old 05-28-2019, 03:51 PM
sklimii's Avatar
Thread Starter
Join Date: Apr 2012
Location: Summerville, South Carolina
Posts: 18,321
Received 2,858 Likes on 2,587 Posts
Default misfires today - RESOLVED

went for an afternoon drive and car started misfiring and acting like it was going to stall. Pulled over and scanned with a P305 and P1316. Figured since I had a spare coil in the trunk, I'd swap and see if things got any better.

took the coil cover off and noticed that SEVERAL of the leads going into the coil connections were no longer insulated and looked to be making contact with other damaged leads . Looks like time and heat had taken their toll and the insulation had broken off. In the interest of getting back on the road, I wrapped each damaged section with a bit of electrical tape. Any remaining insulation is brittle so I will need to replace the harness soon.

left the coil as is for now and put everything back together, fired her up, cleared codes and drove about 30 miles round trip with no further issues.

Just something for those of us with aging cars to be mindful of. Sorry no pics as I didn't have my cell with me
 
The following 3 users liked this post by sklimii:
Jon89 (05-29-2019), MRomanik (05-29-2019), RJ237 (05-28-2019)
  #2  
Old 05-28-2019, 03:57 PM
Senior Member
Join Date: Jul 2018
Location: Massachusetts
Posts: 195
Received 64 Likes on 34 Posts
Default

I can speak from experience that that's a great resolution to P030x and P1316 code bundle. Spent months figuring out why I was getting P0307 and P1316. I get what you're saying about heat, age, and plastic, though. It is indeed inevitable.

How many miles do you have on your car, again? I forgot. It's pretty high, right?
 
  #3  
Old 05-28-2019, 04:09 PM
sklimii's Avatar
Thread Starter
Join Date: Apr 2012
Location: Summerville, South Carolina
Posts: 18,321
Received 2,858 Likes on 2,587 Posts
Default

Currently at 178200.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
elardizabal
X-Type ( X400 )
24
12-22-2012 06:54 PM
theoutcast13
X-Type ( X400 )
9
12-13-2012 09:57 PM
leestang66
S-Type / S type R Supercharged V8 ( X200 )
6
10-21-2009 06:30 AM
starvinmarvin08
X-Type ( X400 )
0
05-25-2009 01:23 PM
kjanelle
XK8 / XKR ( X100 )
3
04-01-2009 10:34 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: misfires today - RESOLVED


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: