XK8 / XKR ( X100 ) 1996 - 2006

Replacing Brake Switch to no Avail

 
  #1  
Old 07-09-2019, 05:38 PM
SamtheSham's Avatar
Senior Member
Thread Starter
Join Date: Dec 2016
Location: S.W.Florida
Posts: 428
Received 82 Likes on 65 Posts
Default Replacing Brake Switch to no Avail

In a previous thread I had discussed the infamous "Cruise control no Avail/Check rear lights" Warning. I just replaced the brake switch light with a new one supplied by the local NAPA store. All looked good for a total of approx. 5 miles , then suddenly the warning was baaaack! Anyone have any ideas? Surely the NAPA store would not have a bad switch?
 
  #2  
Old 07-09-2019, 11:43 PM
giandanielxk8's Avatar
Veteran Member
Join Date: Oct 2012
Location: Puerto Rico
Posts: 1,950
Received 281 Likes on 207 Posts
Default

Originally Posted by SamtheSham View Post
In a previous thread I had discussed the infamous "Cruise control no Avail/Check rear lights" Warning. I just replaced the brake switch light with a new one supplied by the local NAPA store. All looked good for a total of approx. 5 miles , then suddenly the warning was baaaack! Anyone have any ideas? Surely the NAPA store would not have a bad switch?

Either the new brake switch is faulty, your lights are actually not working, or a melted ground at the tail lights. That last one is a looooooong shot because it is a problem common to the early cars, not the late Victory Editions.
 
  #3  
Old 07-10-2019, 06:30 AM
SamtheSham's Avatar
Senior Member
Thread Starter
Join Date: Dec 2016
Location: S.W.Florida
Posts: 428
Received 82 Likes on 65 Posts
Default

The problem only started after driving approx. 5 miles, just as it had in the past. Possibly a module problem??
 
  #4  
Old 07-10-2019, 07:50 AM
Veteran Member
Join Date: Jan 2009
Location: Raleigh, NC
Posts: 9,908
Received 2,110 Likes on 1,603 Posts
Default

More likely a faulty switch problem. The OEM microswitches are of mediocre quality with some really lousy soldering....
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lbeagles
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
4
07-24-2014 05:45 PM
Cabotom
S-Type / S type R Supercharged V8 ( X200 )
15
03-09-2013 03:29 PM
PerrysJag
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
2
02-19-2013 03:46 PM
m0t0rm0uth
XJ6 & XJ12 Series I, II & III
1
11-20-2009 05:24 PM
paul11117606
X-Type ( X400 )
1
02-24-2008 10:19 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Replacing Brake Switch to no Avail


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: