Help with air con issue... Please!

 
  #1  
Old 12-03-2018, 11:37 PM
Member
Thread Starter
Join Date: Sep 2017
Location: Port Noarlunga in South Australia
Posts: 64
Received 11 Likes on 6 Posts
Default Help with air con issue... Please!

2003 s-type 4.2L. (X202)
I am having issues with the air con warming up every time I stop at lights and the revs drop down. It have had the entire system checked and it is in perfect order, including the electrics. I found a TSB (JTB00183) that details a fix for this exact problem which involves a de-gas, removing a plate from the compressor and reversing the order of the valve and valve spring. In the TSB it states for the V6 only but I have been told that it also works on the 4.2L V8. Does anyone out there know if this is true? Cheers... Dave.
 
  #2  
Old 12-04-2018, 02:32 AM
Join Date: Feb 2010
Location: Adelaide Stralia
Posts: 19,243
Received 5,662 Likes on 4,065 Posts
Default

Dave,

I believe so, as the compressor is the same basic unit.

I had that TSB in hand when my V6 had the same issues, and prior to doing the degas and swap of that spring, we took it for a serious "hard workout", as in near redline, and that sorted it once and for all.
 
  #3  
Old 12-05-2018, 12:25 AM
Member
Thread Starter
Join Date: Sep 2017
Location: Port Noarlunga in South Australia
Posts: 64
Received 11 Likes on 6 Posts
Default

Gave it a "fang" this arvo. got it up to about 6000rpm. A lot of fun but unfortunately the air con still not working correctly so I will give the chap at Alldrive a call and see if he can reverse the compressor valve. ... Cheers
 
The following users liked this post:
Grant Francis (12-05-2018)
  #4  
Old 12-05-2018, 03:19 AM
Join Date: Feb 2010
Location: Adelaide Stralia
Posts: 19,243
Received 5,662 Likes on 4,065 Posts
Default

BUGGA,
 
  #5  
Old 01-15-2019, 09:20 PM
Member
Thread Starter
Join Date: Sep 2017
Location: Port Noarlunga in South Australia
Posts: 64
Received 11 Likes on 6 Posts
Default Air conditioner

I had the spring & valve switched around as per the TSB for my air conditioner compressor...Success!!! No longer blows warm air when stopped at lights and at idle temp is about 4 degrees C. The TSB says for the 3.0L engines only but my 4.2L has the same compressor and it works a treat...Cool driving
 
  #6  
Old 01-16-2019, 12:48 AM
OzXFR's Avatar
Veteran Member
Join Date: Feb 2014
Location: Adelaide, South Australia
Posts: 3,874
Received 1,092 Likes on 907 Posts
Default

What's the opposite of bugga?
I suppose it's bewdy!
 
  #7  
Old 01-16-2019, 12:54 AM
Member
Thread Starter
Join Date: Sep 2017
Location: Port Noarlunga in South Australia
Posts: 64
Received 11 Likes on 6 Posts
Default

Yep... after 3 days of over 40 degree temperatures.... it sure is bewdy !!!
 
  #8  
Old 01-16-2019, 02:58 AM
Join Date: Feb 2010
Location: Adelaide Stralia
Posts: 19,243
Received 5,662 Likes on 4,065 Posts
Default

BEER TIME.

Well done, and another for the "outside the box" thinking.
 
The following users liked this post:
Dave1963 (01-16-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
streamsaver
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
8
12-19-2018 11:30 AM
TangoFox5
XJS ( X27 )
21
12-10-2018 04:57 PM
Geoffrey Fake
XJ ( X351 )
4
12-04-2018 06:52 PM
alabbasi
XJS ( X27 )
2
12-04-2018 08:08 AM
Howie1971
XJ6 & XJ12 Series I, II & III
5
12-02-2018 02:40 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Help with air con issue... Please!


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: