X-Type ( X400 ) 2001 - 2009
Sponsored by:
Sponsored by:

Starts up but cuts out after 2-3 seconds.

 
  #1  
Old 05-31-2019, 12:33 AM
Junior Member
Thread Starter
Join Date: May 2019
Location: sennestadt
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default Starts up but cuts out after 2-3 seconds.

Hi, I have an X-Type 2.2; 2008 Diesel. It starts OK runs for a couple of seconds then cuts out, coil light flahes and short alarm (buzzing) buzzing noise from engine. I saw a thread from a couple of years back where a guy had the same problem I have tried all the advice given to him, to no avail. So far I have:
Replaced the fuel rail.
Cleaned the EGR unit.
Inserted a blanking plate.
I would be grateful if anyone could provide any other self help advice I could try myself, if only a tempoary fix to get it to a garage.

Thanks in advance.
 
  #2  
Old 05-31-2019, 01:04 AM
Veteran Member
Join Date: Mar 2017
Location: Utah
Posts: 2,897
Received 359 Likes on 335 Posts
Default

Search here for "blinking coil light" & do the Mr. Muscle fix.
 
  #3  
Old 06-01-2019, 12:39 PM
Junior Member
Join Date: Jun 2014
Location: italy
Posts: 26
Received 0 Likes on 0 Posts
Default

I had exactly the same problem and was EGR that lost the rounded plate that is the valve so after firing exaust gas entered in the inlet manifold instead of clead air shutting off the engina. But blanking EGR cured because no more exaust gas entered. But you said that you have blanked EGR so this isn't the case . Sorry my case is not your but symptoms are the same.
 
  #4  
Old 06-01-2019, 10:57 PM
Junior Member
Thread Starter
Join Date: May 2019
Location: sennestadt
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by essepi View Post
I had exactly the same problem and was EGR that lost the rounded plate that is the valve so after firing exaust gas entered in the inlet manifold instead of clead air shutting off the engina. But blanking EGR cured because no more exaust gas entered. But you said that you have blanked EGR so this isn't the case . Sorry my case is not your but symptoms are the same.
Hi, Yes I have put in the blanking plate so no exhaust gas gets there. Still the problem exists. Thanks nayway.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
xk8v8
XK8 / XKR ( X100 )
10
09-17-2017 04:55 AM
Bongani
S-Type / S type R Supercharged V8 ( X200 )
6
02-03-2016 09:58 AM
hollywood4130
XJ XJ6 / XJR6 ( X300 )
5
09-26-2014 07:05 AM
chrisainley
XJS ( X27 )
4
01-06-2014 03:52 AM
lisa44
X-Type ( X400 )
8
02-27-2012 10:44 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Starts up but cuts out after 2-3 seconds.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: