XE ( X760 ) 2015 -

Defective alternator

 
  #1  
Old 04-12-2019, 02:35 PM
Member
Thread Starter
Join Date: Jan 2017
Posts: 30
Received 5 Likes on 1 Post
Default Defective alternator

Driving a 2017 35T XE and Jaguar has had to replace the alternator 3 times in two years. At the second replacement, a month ago they claimed to have found a leak that was spraying on the alternator and causing it to falter. Now a month later it's in the shop again with the same Charging system Fault warning light. Is anyone else having this problem or has anyone heard of a fix.....what a lemon
 
  #2  
Old 04-12-2019, 04:27 PM
Fraser Mitchell's Avatar
Veteran Member
Join Date: Dec 2009
Location: Crewe, England
Posts: 7,321
Received 1,569 Likes on 1,306 Posts
Default

I'm driving a 2017 too, and it's OK so far although I'm only on 12.5k miles so far, (took it over in January on 10k miles). Yours is not a common fault at all on this forum. Did you have the car from new ?
 
  #3  
Old 04-13-2019, 08:33 AM
DJS
DJS is offline
Veteran Member
Join Date: May 2013
Location: Metrowest Boston
Posts: 4,253
Received 994 Likes on 761 Posts
Default

Seem to recall some water pump issues discussed on the F-type forum - not common, but seemingly not that rare either.
 
  #4  
Old 06-12-2019, 09:52 AM
Member
Thread Starter
Join Date: Jan 2017
Posts: 30
Received 5 Likes on 1 Post
Default

Yes, have it from new.
they replaced the alternator, then replaced a voltage sensor and on my third visit they said they improved some 'Ground' connections.
it seems to be behaving itself now,,,,got my fingers crossed.
The Jag dealer told me that even though I was getting the same error light on the dash that when they check the code it was different each time,,,,lets hope.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
afterburner1
XJS ( X27 )
1
03-29-2017 07:00 PM
afterburner1
XJS ( X27 )
2
03-19-2017 10:08 AM
Roger Mabry
XJ6 & XJ12 Series I, II & III
24
12-17-2016 08:55 AM
muckbury
S-Type / S type R Supercharged V8 ( X200 )
3
11-03-2013 09:20 AM
love's_jag
X-Type ( X400 )
3
02-14-2012 10:35 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Defective alternator


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: