XJ ( X351 ) 2009 - Onwards

Radio,CD static noise

 
  #21  
Old 01-07-2015, 03:07 PM
Senior Member
Join Date: Nov 2010
Location: Torrance, CA
Posts: 961
Received 127 Likes on 101 Posts
Default

Sounds like an old gremlin that crept up from the X350. My '05 XJ8L has the same issue intermittently that always goes away after a restart. Has nothing to do with electromagnetic interference from cell phones. More like a wiring issue. I remember a thread where somebody used a multi-key hard reset similar to Ctrl-Alt-Del and it worked. Hah! Some things about our car will never change, such as these electric gremlins.

Cheers,
Wolfy
 
  #22  
Old 01-07-2015, 08:59 PM
Member
Join Date: Mar 2008
Location: Dallas, TX
Posts: 54
Likes: 0
Received 3 Likes on 3 Posts
Default

Originally Posted by rob.drummond View Post
Hey Mullisrd.

There is a service bulletin on this? I have a 2012 XJ S/C with these symptoms as well. It only happens to my car when it is really hot outside and the car is very hot. I'll have to ask my dealer about the service bulletin.

Thanks
Rob
Yes, there is a SB. I will have to get the specific number when I get the car back. I do concur that temperature has something to do with it as it seems worse when it's warmer. I was concerned that I was going to get a "we could not duplicate the problem" but the dealer informed me of the SB and indicated the fix was the replacement of the instrument cluster. I will update when I get the car back in a few days.
 
  #23  
Old 01-14-2015, 09:49 PM
Member
Join Date: Mar 2008
Location: Dallas, TX
Posts: 54
Likes: 0
Received 3 Likes on 3 Posts
Default

It looks like the cluster replacement fixed the static problem. The invoice shows the service action number as 883020. I don't know if that is the service bulletin number or not.
 
  #24  
Old 01-22-2015, 06:19 AM
rob.drummond's Avatar
Junior Member
Join Date: Dec 2013
Location: Ottawa
Posts: 29
Likes: 0
Received 7 Likes on 7 Posts
Default

Thank you Mullisrd. I'll ask my dealer to look up that number.

Rob
 
  #25  
Old 07-30-2018, 10:18 PM
Senior Member
Join Date: Mar 2011
Location: Texas
Posts: 161
Received 9 Likes on 9 Posts
Default

My 2013 XKR occasionally suffers from this static issue.
Has anyone else experienced this? And if so how did they correct it?
mine is a CPO and currently at San Antonio Barrett jaguar but theyíre telling me since they canít replicate they wonít be able to repair anything in particular is anybody familiar with this issue or have the service bulletin number for this particular issue?
Thanks
DAG
 
  #26  
Old 06-26-2019, 02:49 PM
Junior Member
Join Date: Feb 2019
Location: Chicago
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

[QUOTE=dag82;1938979]

My 2013 XKR occasionally suffers from this static issue.
Has anyone else experienced this? And if so how did they correct it?
mine is a CPO and currently at San Antonio Barrett jaguar but theyíre telling me since they canít replicate they wonít be able to repair anything in particular is anybody familiar with this issue or have the service bulletin number for this particular issue?
Thanks
DAG
My 2015 XKR convertible with headrest speakers does this occasionally also. Will the sb 883020 solve the problem?
 
  #27  
Old 06-28-2019, 12:22 AM
Senior Member
Join Date: Oct 2018
Location: California, USA
Posts: 257
Received 37 Likes on 26 Posts
Default

I rarely hear static sound, but when I do it is always when Iím on a phone call as I enter the car. It goes away a couple seconds after having the car on. My experience seams consistent with some of the other posts above. It suggests interference may be the problem. As it is common to all your music sources, it must be a component common to all of them. Perhaps the amp? Iím not sure.

EDIT: Just read through the whole thread. I would check the range of model years covered by the service bulletin. If yours is in range, then it makes the most sense to be the issue. I donít have the SB, so I canít confirm this for you. Dealer should be able to tell you.
 

Last edited by Nedoerr; 06-28-2019 at 12:17 PM.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
JimC64
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
31
05-30-2016 03:04 PM
ziondio
XK8 / XKR ( X100 )
6
01-28-2016 09:33 PM
ChrisJay
XF and XFR ( X250 )
2
09-27-2015 09:08 AM
UKnFor-dluv-expat
X-Type ( X400 )
1
09-26-2015 08:40 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Radio,CD static noise


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: