XJ6 & XJ12 Series I, II & III 1968-1992

stalls constantly.

 
  #1  
Old 11-16-2014, 03:37 AM
Member
Thread Starter
Join Date: Aug 2014
Location: paynesville, victoria, australia
Posts: 39
Likes: 0
Received 8 Likes on 8 Posts
Default stalls constantly.

after having a head rebuild, on my s3 4.2, I'm experiencing some new issues. whilst driving along, the engine stalls. when I try to start the car straight away, it won't fire. however if I let it sit for 5 minutes, it starts no problem.
what have I bloody done?
 
  #2  
Old 11-16-2014, 04:31 AM
Join Date: Feb 2010
Location: Adelaide Stralia
Posts: 19,675
Received 5,839 Likes on 4,184 Posts
Default

The list could be long.

My ideas are:

Loss of spark, as in ign module (front of inlet manifold) is getting hot, dying, shuts down, cools a tad, away you go.

Fuel pump is stopping. Relay?, or switch contacts inside the airflow meter?.

Some earth straps have been left off when the head was refitted.

Basically some diagnosis, is it losing spark or fuel?.
 
The following users liked this post:
Saemetric (11-16-2014)
  #3  
Old 11-17-2014, 03:46 AM
Member
Thread Starter
Join Date: Aug 2014
Location: paynesville, victoria, australia
Posts: 39
Likes: 0
Received 8 Likes on 8 Posts
Default

Originally Posted by Grant Francis View Post
The list could be long.

My ideas are:

Loss of spark, as in ign module (front of inlet manifold) is getting hot, dying, shuts down, cools a tad, away you go.

Fuel pump is stopping. Relay?, or switch contacts inside the airflow meter?.

Some earth straps have been left off when the head was refitted.

Basically some diagnosis, is it losing spark or fuel?.
I spoke to my local mechanic today who has worked on a few jags in the area. he basically said the same things as you just mentioned.
seems to be spark. the car car doesn't cough and splutter like its out of fuel. it just turns off.
 
  #4  
Old 11-17-2014, 05:21 AM
Join Date: Feb 2010
Location: Adelaide Stralia
Posts: 19,675
Received 5,839 Likes on 4,184 Posts
Default

OK.

Ignition col is another hot contender. They are getting OLD now, and are in a dumb location, so get very hot and that will cause an instant shutdown, then it cools, then you go some more.

It is strongly related to the ignition amp unit. I usually fit a new module and coil as a "cover the bases" method.

The engine earth strap/s are the cause of strange shutdowns sometimes. They should be checked and even removed and cleaned, just to be sure. If it does not fix this issue, it will certainly do no harm.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kingdom worker
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
2
10-02-2015 09:37 PM
JaguarSV8
New Member Area - Intro a MUST
9
10-01-2015 01:58 AM
oldjaglover
XK8 / XKR ( X100 )
8
09-29-2015 03:27 PM
Mark SF
XJ XJ8 / XJR ( X308 )
4
09-28-2015 01:51 PM
shootingbrake
X-Type ( X400 )
4
09-23-2015 10:54 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: stalls constantly.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: