XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

Exhaust gunshots?

 
  #1  
Old 01-14-2019, 03:05 AM
Senior Member
Thread Starter
Join Date: Oct 2015
Location: Vancouver
Posts: 578
Received 186 Likes on 137 Posts
Default Exhaust gunshots?

I was wondering if anyone had some insight into why my car might still be firing off very loud 'gunshot' type noises from the passenger side exhaust? The entire fuel-ignition system from injectors and harnesses to fuel filter has been redone. The issue occures only on that side when taking pressure off the pedal and idling/coasting at highway speeds. My car has side exit exhausts with free-flow mufflers so it is quite noticable.
 
  #2  
Old 01-14-2019, 08:47 AM
Veteran Member
Join Date: Mar 2008
Location: Pacific Northwest USA
Posts: 20,158
Received 6,562 Likes on 4,864 Posts
Default

Originally Posted by VancouverXJ6 View Post
I was wondering if anyone had some insight into why my car might still be firing off very loud 'gunshot' type noises from the passenger side exhaust?
"Still"?

When did this begin?

It might be backfiring....mild to huge....due to unburnt fuel

But, as I understand it, exhaust "popping" (different than an actual backfire) can also be a pressure-reversal situation within the exhaust pipe....for reason that I understand when I'm reading them but, afterwards, sorta fade away.

Lots of info out there.

Your "gunshot" description sounds like an actual backfire......which would make us look 1) poor ignition on that bank or 2) overfueling on that bank

More later; gotta get to work !

Cheers
DD
 
  #3  
Old 01-14-2019, 05:19 PM
Senior Member
Join Date: Nov 2015
Location: Kamloops BC
Posts: 374
Received 104 Likes on 77 Posts
Default

I’d look into the advance on the distributor. It might not be returning quick enough
 
  #4  
Old 01-14-2019, 05:22 PM
Senior Member
Thread Starter
Join Date: Oct 2015
Location: Vancouver
Posts: 578
Received 186 Likes on 137 Posts
Default

Its a Marelli car, the oldest ignition component on there would be the spark plugs at 40,000km aside from that I can't see how there could be an ignition issue on the one side when everything else is very 'new'

I wish my dashcam had proper audio recording it would explain it better.
 
  #5  
Old 01-14-2019, 06:24 PM
Veteran Member
Join Date: Dec 2014
Location: California
Posts: 1,291
Received 456 Likes on 312 Posts
Default

Originally Posted by VancouverXJ6 View Post
Its a Marelli car, the oldest ignition component on there would be the spark plugs at 40,000km aside from that I can't see how there could be an ignition issue on the one side when everything else is very 'new'

I wish my dashcam had proper audio recording it would explain it better.
On a Marelli system there are separate power modules for each bank, and separate coils for each bank, perhaps one of those components would explain poor ignition on only one bank.
 
The following users liked this post:
Greg in France (01-15-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jagxkrtoofast
XK8 / XKR ( X100 )
17
09-29-2014 07:43 PM
DJ99
S-Type / S type R Supercharged V8 ( X200 )
5
05-24-2012 08:10 PM
gragner66
Sights N Sounds
5
10-14-2011 07:04 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Exhaust gunshots?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: