XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

Is this motor mount bad?

 
  #1  
Old 06-03-2019, 02:42 PM
Spikepaga's Avatar
Veteran Member
Thread Starter
Join Date: Apr 2011
Location: Galleria Area Houston, Texas
Posts: 2,363
Received 341 Likes on 241 Posts
Default Is this motor mount bad?

Hello gents;

I am gathering all the (multiple) parts necessary to replace what constitutes the transmission mount in my 95 AJ16 XJS, which should be an easy and quick job according to my “generic” mechanic



While I wait for the other other coil and the buffers to come in, I have been continuing my project of cleaning the engine bay and replacing lost stickers. I went further down into the engine to clean all the transmission fluid from a ruptured line several months back, and I noticed the motor mount seems delaminated from the metal plate.


Is this supposed to look like this on top? Or is it all held together differently ?
 

Last edited by Spikepaga; 06-03-2019 at 04:04 PM.
  #2  
Old 06-03-2019, 03:37 PM
Veteran Member
Join Date: Jul 2010
Location: Austin tx and Daytona FL.
Posts: 6,585
Received 896 Likes on 690 Posts
Default

Transmission mount.duh!!
 
  #3  
Old 06-04-2019, 06:43 AM
Veteran Member
Join Date: Apr 2014
Location: Kent, UK
Posts: 1,664
Received 957 Likes on 762 Posts
Default

Mark,

At first glance, that engine mount seems ok. Where can you see delamination happening?

Paul
 
  #4  
Old 06-04-2019, 09:48 AM
Spikepaga's Avatar
Veteran Member
Thread Starter
Join Date: Apr 2011
Location: Galleria Area Houston, Texas
Posts: 2,363
Received 341 Likes on 241 Posts
Default

Originally Posted by ptjs1 View Post
Mark,

At first glance, that engine mount seems ok. Where can you see delamination happening?

Paul
Thanks for your reply, Paul

i see what seems like a separation of the metal and the rubber in the circled area


 
  #5  
Old 06-05-2019, 05:19 AM
Senior Member
Join Date: Dec 2017
Location: Brookfield CT
Posts: 333
Received 49 Likes on 45 Posts
Default

Originally Posted by Spikepaga View Post
Thanks for your reply, Paul

i see what seems like a separation of the metal and the rubber in the circled area

You can try to gently lift the engine using a floor jack and watch the engine mount as someone lifts. Otherwise watch the mount when you or someone puts the car in drive or reverse, with brake on and watch as the engine tries to move the car as you give it gas. If the mounts are bad, the engine torque will want to rotate itself up from the mount and will be evident. Reverse to watch the other engine mount lift.
 
The following users liked this post:
Vee (06-05-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PeteK812
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
0
07-21-2018 04:26 AM
pdog2000
XJ XJ8 / XJR ( X308 )
22
03-24-2015 10:24 AM
jepjrmd
XJ XJ8 / XJR ( X308 )
2
08-06-2013 07:53 AM
philhef
XK8 / XKR ( X100 )
44
06-15-2013 05:21 PM

Currently Active Users Viewing This Thread: 4 (0 members and 4 guests)
 

Thread Tools
Search this Thread
Quick Reply: Is this motor mount bad?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: