Center Display Failure - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
I-Pace EV 2018 - Onwards
Sponsored by:
Sponsored by:

Center Display Failure

 
  #1  
Old 12-11-2018, 08:02 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default Center Display Failure

OK after literally one day with the car the Center Displays (both of them) went out. Looked on the European Jaguar Forum and folks started reporting this earlier this month: https://www.ipaceforums.co.uk/viewto...cked+out#p9398

Be aware that initial fixes didn't take suggesting, if you have this problem, the dealer should do a couple of test drives to make sure the fix takes. If it were just software this would be fixible remotely, I'm guessing some faulty control units made it into cars recently. I'll bet they either changed suppliers or that they did some kind of in-line update that caused problems. My car is going on a flatbed back to Jaguar Portland (who has been really helpful about resolving this, nice folks). Hopefully I'll have the car back by week end.

Be aware that Jaguar Roadside Assistance has issues with our VIN numbers (it will take a number of times and the full VIN to identify the car), apparently doesn't have the right information about towing in Portland (their screens come up blank but according to the dealership we get up to 500 miles), but the folks are really nice and I figure this will give me a nice winter story to tell. (I'm off on the road for the next few days anyway and the dealer agreed to put on my Snow tires which will save me a trip to he tire shop, so, assuming this gets fixed I'm good). I'll post updates as I get them.
 
  #2  
Old 12-11-2018, 09:27 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default Picture

 

Last edited by enderle; 12-11-2018 at 09:30 PM.
  #3  
Old 12-12-2018, 10:26 AM
Senior Member
Join Date: Mar 2018
Location: San Jose, CA
Posts: 147
Thanked 12 Times in 9 Posts
Default

yikes ! no issues here. but good to know.
 
  #4  
Old 12-12-2018, 12:17 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default

Fingers crossed for you, and hope your dealer is closer than mine is. 160 miles made this a PITA.
 
  #5  
Old 12-14-2018, 03:59 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default

Just got word from the dealer in Portland (they've been great) that the problem was in software. If true this should have been fixable remotely but without the center screens, I can't initiate a patch and Jaguar seems to not want to patch remotely. Given this car apparently is running embedded Windows I'm guessing the concerns surrounding the software update screen Windows has is giving them pause. I do expect a future software update will be better able to address this. But with computers screen failures are always problematic even when they are caused by driver or OS updates. They tell me I should get the car back again next week as they wanted to address a few more things and given the EU forum indicated the problem could recur they are making sure it doesn't.

I'd shared my I-Pace issue with the Sports Car club I belong to, they have a Tesla X that has been in the shop for 3 months because of an inability to get parts. So it really could be a ton worse.
 

Last edited by enderle; 12-14-2018 at 04:16 PM. Reason: Tesla X addition
  #6  
Old 12-18-2018, 12:05 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default

Update, still don't have car back, once fixed I requested the dealer keep it for a couple of days to make sure the display stays fixed. It didn't, they are now working with Jaguar to see if they can craft a perminent fix. (Don't want the car going back and forth to the dealership every other week given the trip goes from 160 miles to something like 250 miles this time of year). When you pick up your cars you might ask if the dealer has checked for this problem as it is a PTA to deal with from home.
 
  #7  
Old 12-19-2018, 10:45 PM
Junior Member
Join Date: Dec 2018
Location: Irvine, CA
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Display issue

My center displays just gave out tonight. Tried turning the car off and on several times but no luck.
Guess I'll be calling the dealer tomorrow.

I have the Genius walk through Friday so may wait for the rep to show up and discuss this issue....

Will send an update if I find a fx.

Chet
 
  #8  
Old 12-20-2018, 02:33 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default

I'm told the patch to fix this is due tomorrow so fingers crossed for both of us.
 
  #9  
Old 12-28-2018, 05:41 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default

Patch took yesterday, car was delivered back to me today and is working fine. Given this was a software issue everyone else will likely get the patch with the next over the air update. Whew...
 
  #10  
Old 01-02-2019, 12:14 PM
Junior Member
Join Date: Sep 2018
Location: Miami
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Wonder if this is why my First Edition has been delayed since 12/5. Dealer was told that Jaguar was at the Brunswick port in GA since 12/12, but that they were waiting for a "software" update.
 
  #11  
Old 01-02-2019, 07:03 PM
enderle's Avatar
Thread Starter
Join Date: Jan 2012
Location: Bend, OR
Posts: 2,184
Thanked 448 Times in 329 Posts
Default

That would be my guess, I'll bet they held delivories until this patch was in place. It looks like a prior patch was the problem. Mine continues to work fine but I know they had issues getting the car to accept the patch. There is a clear learning curve to doing over the air patching right. Apparently/sadly Jaguar is still at the front end of that curve. Good news is that the eventual fix is all software and process so it isn't a design issue.
 
  #12  
Old 02-08-2019, 01:01 PM
Junior Member
Join Date: Feb 2019
Location: Odessa, FL
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

My First Edition had this problem, too. Mine was in over Christmas, I picked it up patched on 12/27 and it has been very stable since (that was the second patch; the first one a couple weeks prior didnít fix it, as noted above). My dealer gave me a loaner I-Pace to drive while mine was in the shop, which was very cool of them!
 
The Following User Says Thank You to kolars For This Useful Post:
enderle (02-09-2019)
  #13  
Old 02-17-2019, 09:34 AM
mjsammon's Avatar
Senior Member
Join Date: Nov 2011
Location: Northern New Jersey, USA
Posts: 239
Thanked 23 Times in 21 Posts
Default

I just experienced this yesterday.
Powered on the vehicle, backed it out of the garage and noticed the center displays were dark.
Turned it off and waited a few minutes. Powered back on, center displays were still dark.
I really needed to be somewhere so I started driving. Halfway down my street the displays came on.

When I returned home I connected the I-Pace to my WiFi but the firmware updates screen indicated no new updates were available.
Is this something only the dealer can update?
 
  #14  
Old 02-17-2019, 02:22 PM
Junior Member
Join Date: Feb 2019
Location: Odessa, FL
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by mjsammon View Post
I just experienced this yesterday.
Powered on the vehicle, backed it out of the garage and noticed the center displays were dark.
Turned it off and waited a few minutes. Powered back on, center displays were still dark.
I really needed to be somewhere so I started driving. Halfway down my street the displays came on.

When I returned home I connected the I-Pace to my WiFi but the firmware updates screen indicated no new updates were available.
Is this something only the dealer can update?

Yes, I think so. Mine had to be patched by the dealer, at least . . .
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ish
XF and XFR ( X250 )
0
09-21-2014 09:48 PM
lozzer65
S-Type / S type R Supercharged V8 ( X200 )
6
04-15-2014 05:59 PM
Muts_nuts
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
5
01-14-2014 02:23 AM
pilotcraig
XK8 / XKR ( X100 )
1
10-16-2011 08:06 PM
jagpro69
XK8 / XKR ( X100 )
2
05-23-2009 09:34 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Center Display Failure


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: