X-Type ( X400 ) 2001 - 2009
Sponsored by:
Sponsored by:

Ecm and a/c

 
  #1  
Old 06-20-2019, 02:13 AM
Junior Member
Thread Starter
Join Date: Sep 2016
Location: Ohio
Posts: 9
Received 0 Likes on 0 Posts
Default Ecm and a/c

2004 Jaguar X-Type 2.5 So recently I had to have a used ecm reprogrammed to my car. I received it and my cluster today and installed them. Turned the car over and the check engine light is still on. My question is does that mean I need to have the code removed from a garage (like is that normal to still have the engine light on) or should the code have already been taken off because of the new ecm? Am very confused because I assumed the code would be gone when I started the car up.

Also while I waited for the new ecm to come in I decided I wanted to fix my a/c. So I replaced the compressor, accumulator, condenser and the orifice. I bought solvent and just flushed the evaporator for an hour to clean any debris. Now I know there was oil already in the compressor before installing it. So I am wondering do I need to just add the refrigerant or more oil and refrigerant together? I just want to make sure before I buy the refrigerant. I notice some say they have oil in them and some donít.
 
  #2  
Old 06-20-2019, 05:09 PM
Veteran Member
Join Date: Mar 2017
Location: Utah
Posts: 2,898
Received 359 Likes on 335 Posts
The following users liked this post:
Luckiecharm (06-20-2019)
  #3  
Old 06-20-2019, 06:10 PM
Junior Member
Thread Starter
Join Date: Sep 2016
Location: Ohio
Posts: 9
Received 0 Likes on 0 Posts
Default

So had the code ran and it’s saying the P0057 again. Had the code wiped and after a couple minutes it popped back up. So I am not sure if I even needed an ecm. Checked all vacuum lines too. So now am wondering should I change the O2 sensor now for the fourth time.
 

Last edited by Luckiecharm; 06-20-2019 at 06:14 PM.
  #4  
Old 06-20-2019, 07:25 PM
Veteran Member
Join Date: Mar 2017
Location: Utah
Posts: 2,898
Received 359 Likes on 335 Posts
Default

So here is my caution, IF you replaced them (it) with lesser expensive non-OEM ones (usually cheaper internet buys) there is post after post in this forum of frustration where members (sometimes after multiple changes) finally break down and purchase the correct part......and bingo......works.

Curious if this is the code you had, why the ECM/cluster change?
 
  #5  
Old 06-20-2019, 08:58 PM
Junior Member
Thread Starter
Join Date: Sep 2016
Location: Ohio
Posts: 9
Received 0 Likes on 0 Posts
Default

Yes this is the code as to why I had the ecm changed. The garage checked the O2 sensor and wiring harness and both were fine so they determined it was the ecm. Now am thinking it wasn’t the ecm. I think I used kwiksen the last two times (in a year now)and a bosch one three years ago when I first encountered the code. I looked up oem ones but am not sure which ones really are the oem ones on eBay. There is a Delphi, denso, and ntk. They say they are oem. Not sure if that is true or not lol. But thank you though.
 
  #6  
Old 06-21-2019, 02:58 AM
Veteran Member
Join Date: Mar 2017
Location: Utah
Posts: 2,898
Received 359 Likes on 335 Posts
Default

Sorry to say, I highly doubt the ECM was your problem. Whoever "diagnosed" that was full of manure.

Forget ebay and buy it from a parts supplier (even on internet) like the forum sponser SNG Barret. Many of the "original" one on eBay are the ones I referenced. They say they are real but most aren't.
 
The following users liked this post:
Luckiecharm (06-22-2019)
  #7  
Old 06-22-2019, 12:39 AM
Junior Member
Thread Starter
Join Date: Sep 2016
Location: Ohio
Posts: 9
Received 0 Likes on 0 Posts
Default

I do think you are right about the ecm not being the problem. So now I am ordering the part through Jaguar themselves. Fingers crossed this works and I quit stressing. Thank you very much!
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
car5car
S-Type / S type R Supercharged V8 ( X200 )
1
02-15-2016 07:03 AM
mello12u
X-Type ( X400 )
2
03-29-2015 06:01 PM
pdowning6
XJ XJ6 / XJR6 ( X300 )
3
04-11-2010 01:16 AM
malcfp
XJ XJ6 / XJR6 ( X300 )
0
03-29-2010 01:56 PM
badmojo
S-Type / S type R Supercharged V8 ( X200 )
3
05-04-2007 05:51 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Ecm and a/c


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: