Right rear ABS sensor 05 X-Type - Jaguar Forums - Jaguar Enthusiasts Forum

Notices
X-Type ( X400 ) 2001 - 2009
Sponsored by:
Sponsored by:

Right rear ABS sensor 05 X-Type

  #1  
Old 01-10-2019, 02:37 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Location: Frankfort
Posts: 3
Thanked 0 Times in 0 Posts
Default Right rear ABS sensor 05 X-Type

Just replaced the right rear sensor on my 05 X-Type. Not even 30 days and the abs light came on and the code shows right rear. Any ideas what could be wrong?
 
  #2  
Old 01-10-2019, 02:44 PM
GGG's Avatar
GGG
GGG is offline
Join Date: Dec 2011
Location: Durham, UK
Posts: 107,560
Thanked 9,838 Times in 8,134 Posts
Default

Welcome to the forum heldt4,

I've moved your question from Jaguar Forums Feedback & Suggestion Centre to X-Type forum. This is the place to post technical questions about your model.

Please follow this link New Member Area - Intro a MUST - Jaguar Forums - Jaguar Enthusiasts Forum to the New Member Area - Intro a MUST forum and post some information about yourself and your vehicle for all members to see. In return you'll get a proper welcome and some useful advice about posting to the forum.

Graham
 
The Following User Says Thank You to GGG For This Useful Post:
heldt4 (01-10-2019)
  #3  
Old 01-10-2019, 02:53 PM
Veteran Member
Join Date: May 2009
Location: Yorkshire, England
Posts: 22,832
Thanked 3,328 Times in 2,952 Posts
Default

Bad bearing, bad (new) sensor, bad wiring, etc.
 
The Following User Says Thank You to JagV8 For This Useful Post:
heldt4 (01-10-2019)
  #4  
Old 01-10-2019, 04:36 PM
astromorg's Avatar
Senior Member
Join Date: Feb 2012
Location: Portsmouth, England
Posts: 826
Thanked 402 Times in 259 Posts
Default

Check out the reluctor ring - the toothed/corrugated ring around the drive shaft that the sensor senses. They can corrode and break causing your sort of problem.
 
The Following User Says Thank You to astromorg For This Useful Post:
heldt4 (01-10-2019)
  #5  
Old 01-10-2019, 04:41 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Location: Frankfort
Posts: 3
Thanked 0 Times in 0 Posts
Default

actually I checked the reluctor ring before I installed the new sensor and there were no cracks. It is somewhat rusty, but nothing out of the ordinary
 
  #6  
Old Yesterday, 10:51 AM
Junior Member
Thread Starter
Join Date: Jun 2018
Location: Frankfort
Posts: 3
Thanked 0 Times in 0 Posts
Default ABS

I installed a new sensor and it seems to be working fine. Now I am feeling the ABS engaging on dry pavement. No light on the dash. Any ideas? Could it be the ABS control module?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
davesjag
X-Type ( X400 )
8
01-08-2019 05:27 PM
boringb5
X-Type ( X400 )
3
12-14-2018 06:20 PM
Mike Noneofyourb
New Member Area - Intro a MUST
8
11-15-2018 12:18 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Right rear ABS sensor 05 X-Type


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: