XJ6 & XJ12 Series I, II & III 1968-1992

more problems...

 
  #1  
Old 05-11-2008, 09:45 PM
Junior Member
Thread Starter
Join Date: Apr 2008
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default more problems...

i have a 75 xj12 and i found out that when the car is running that the fuel pump is pumping fuel to the engine and the other tank i dont understand this at all so if i could be told how to fix it i would be most greatfull

thank you
 
  #2  
Old 05-12-2008, 02:13 AM
Join Date: Mar 2008
Location: Powell, Ohio U.S.A. 43065
Posts: 2,521
Likes: 0
Received 57 Likes on 47 Posts
Default RE: more problems...

The most common scenario is left tank overfilling when running on right, as the left fuel return solenoid should be closed but it has failed in the open position. You should be able to hear the return solenoids (inside each rear wheel arch)click open and closed when you have someone press the fuel changeover switch. You can also listen with a stethoscope by popping open the fuel filler and listening for fuel return when the other tank is selected, so long as the tank is not completely full. Obviously the right side one can fail as well...and the same symptom can occur if the changeover ("T") valve is not fully seating in one direction or the other in response to the fuel switch selection. Clamping off the supply line from each tank one at a time will help to determine this fault.

The basic idea is that the pump draws fuel from only one tank at a time, the engine doesn't drink all that is provided, and the remainder must return to the tank from which it was drawn.
 
  #3  
Old 05-13-2008, 09:17 PM
Junior Member
Thread Starter
Join Date: Apr 2008
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default RE: more problems...

ok so i might need a new crossover valve then right?

also the way i have things wired right now is slightly wrong becuase i cannot find a wire to the fuel pump
when i bought the car it didnt have a fuel pump and according to hanyes book there is a wire missing that goes to the fuel pump so im kinda looking for a pic of what it looks like so i can compare

dont laugh at me but right now i have the pump wired to the lights so i have to have the light on for the pump to run so im really confused cuz then the switch to switch tanks dont work becuase really none of the back protion is wired right so im more confused
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Roger Mabry
XJ6 & XJ12 Series I, II & III
5
05-20-2015 09:07 AM
howdoyousayjaguar
XK8 / XKR ( X100 )
11
05-05-2015 06:38 AM
spacemancoco
X-Type ( X400 )
3
03-05-2015 10:29 PM
Tripa
XJ XJ8 / XJR ( X308 )
2
02-10-2015 04:22 AM
Reggie's Dad
Off Topic
37
10-29-2014 08:04 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: more problems...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: