XJS ( X27 ) 1975 - 1996 3.6 4.0 5.3 6.0

Help - Clutch problems

 
  #1  
Old 06-02-2019, 08:02 AM
Senior Member
Thread Starter
Join Date: Mar 2015
Location: Caterham, UK
Posts: 257
Received 55 Likes on 47 Posts
Default Help - Clutch problems

Hi all,

My 90 3.6 manual has developed a clutch issue.

Drove the car last weekend and clutch felt a little odd as free play on the pedal seemed to have increased. Today clutch drag set in after a few hundred yards of driving and I virtually had to push my foot through the floor to disengage.

I have about 1 inch of free play at the pedal which reduces to half of this after vigorous pumping. Fluid is topped up but looks dirty.

At 137k miles and, I believe, still on the original clutch I am fearing the worst but is there any chance this could be a hydraulic issue - maybe slave or master cylinder?

Thanks for reading.

Cheers,

LeeP

 
  #2  
Old 06-02-2019, 11:00 AM
Veteran Member
Join Date: Jan 2012
Location: France
Posts: 8,958
Received 4,471 Likes on 2,849 Posts
Default

Almost for certain you need a new slave cylinder and a new master cylinder, or re-rubber-seal the old ones. It is not worth just doing one, the other will be close behind it, even if it works for now.
 
The following users liked this post:
leep123 (06-03-2019)
  #3  
Old 06-02-2019, 02:17 PM
orangeblossom's Avatar
Veteran Member
Join Date: Feb 2013
Location: uk
Posts: 15,614
Received 2,102 Likes on 1,622 Posts
Default

 

Last edited by orangeblossom; 06-02-2019 at 02:20 PM. Reason: Text disappeared when I uploaded a Photo
  #4  
Old 06-02-2019, 02:27 PM
orangeblossom's Avatar
Veteran Member
Join Date: Feb 2013
Location: uk
Posts: 15,614
Received 2,102 Likes on 1,622 Posts
Default

Hi Lee

When I uploaded the Photo above, all the Text disappeared!
but the Photo is of a Blocked Flexible Pipe from the Clutch of my MGB so might be worth Checking the Flexy Pipe to your XJS Slave Cylinder
 
The following users liked this post:
leep123 (06-03-2019)
  #5  
Old 06-03-2019, 07:06 AM
Senior Member
Thread Starter
Join Date: Mar 2015
Location: Caterham, UK
Posts: 257
Received 55 Likes on 47 Posts
Default

Originally Posted by orangeblossom View Post
Hi Lee

When I uploaded the Photo above, all the Text disappeared!
but the Photo is of a Blocked Flexible Pipe from the Clutch of my MGB so might be worth Checking the Flexy Pipe to your XJS Slave Cylinder
Thanks for persevering OB. I will certainly have a look at the hose as well. Didn't know you had an MGB. We did also for 12 years before the red mist descended and I bought the XJS. If only Jag parts were as cheap as MG!

Thanks also to Greg for his thoughts.

LeeP
 
The following users liked this post:
orangeblossom (06-03-2019)
  #6  
Old 06-03-2019, 08:23 AM
orangeblossom's Avatar
Veteran Member
Join Date: Feb 2013
Location: uk
Posts: 15,614
Received 2,102 Likes on 1,622 Posts
Default

Hi Lee

Some XJS Parts are much cheaper than those for an MGB

Fuel Pump for instance: XJS about 33

MGB about 100!
 
The following users liked this post:
leep123 (06-03-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MannyJag
X-Type ( X400 )
0
04-18-2016 10:17 PM
milleniumaire
XK / XKR ( X150 )
33
03-12-2016 04:30 AM
Gregfromuk
XK8 / XKR ( X100 )
7
10-07-2013 03:03 PM
03Xtype
S-Type / S type R Supercharged V8 ( X200 )
3
04-10-2013 12:07 AM
caimano
X-Type ( X400 )
7
04-26-2012 11:09 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Help - Clutch problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: