XK8 / XKR ( X100 ) 1996 - 2006

"Cruise control not avail/check rear lights"

 
  #1  
Old 06-28-2019, 06:34 PM
SamtheSham's Avatar
Senior Member
Thread Starter
Join Date: Dec 2016
Location: S.W.Florida
Posts: 419
Received 82 Likes on 65 Posts
Default "Cruise control not avail/check rear lights"

So these are the caution lights that suddenly displayed after about 20 minutes of driving on I-75 in S. Florida as I am bringing my new to me 2006 blk. Victory Ed. XK8 home to S.W. Fla. Had been running with the cruise control on a bit to check it out, due to the typical S.Florida drivers I had tapped my brakes to slow down, then the caution lite advised a msg, and the above lite began flashing(it alternated, Cruise-Check). I stopped at a rest area to 'pause for the cause', waited about 15 minutes, got back in and all was good. Ran the cruise control for about 45 minutes, tapped it off again for traffic, and again it failed and displayed same combination of lights, all the way to my home. When I got home, I checked my rear lights and could not find any rear lights inop, and when my wife was following, she did not notice any brake lights inop.
Does anyone have any ideas??
I am starting to work thru the car and see what needs to be done to thsi "New to me" car. I am sure there will be more renovation to be done to this 92,000 mi, but pretty good condition car.
 
  #2  
Old 06-28-2019, 07:11 PM
rothwell's Avatar
Veteran Member
Join Date: Jan 2009
Location: Land O Lakes, Florida
Posts: 1,416
Received 649 Likes on 393 Posts
Default

Sam its a common problem with the brake light switch above the pedal.

Search for that and you will see that, other than it being in a cramped location, the fix is simple.
 
  #3  
Old 06-28-2019, 07:21 PM
SamtheSham's Avatar
Senior Member
Thread Starter
Join Date: Dec 2016
Location: S.W.Florida
Posts: 419
Received 82 Likes on 65 Posts
Default

Great!! Is it just a relocation of wires, or a switch that is in a bade location? I will be down under the panel tomorrow when I get a chance to look at it. Thx for the info.
 
  #4  
Old 06-28-2019, 08:22 PM
rothwell's Avatar
Veteran Member
Join Date: Jan 2009
Location: Land O Lakes, Florida
Posts: 1,416
Received 649 Likes on 393 Posts
Default

The switch needs to be either replaced or repaired. I went for the new one @ about $150.

Lots of info here
 
  #5  
Old 06-29-2019, 01:30 AM
Junior Member
Join Date: Apr 2015
Location: Dayton, Ohio
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default

I had a similar problem, plus it impacted most of the switches on the center control panel. Turns out, the tech found a short in the headlight leveling switch. They seem to be on the same circuit. 2006 XK8 convertible with 104,000 miles located in Dayton, Ohio
 
  #6  
Old 06-29-2019, 05:56 AM
SamtheSham's Avatar
Senior Member
Thread Starter
Join Date: Dec 2016
Location: S.W.Florida
Posts: 419
Received 82 Likes on 65 Posts
Default

Looks like the Repair saga($$$$) begins. I hope it is not too difficult to reach as I try to do as much repair as possible, and I am not exactly the smallest person in my neighbor hood. Will try to check it out today. Don't suppose there is a Ford/Lincoln exchange part??
 
  #7  
Old 06-29-2019, 09:46 AM
Member
Join Date: Jun 2018
Location: Las Vegas, NV
Posts: 30
Likes: 0
Received 9 Likes on 5 Posts
Default

You might also want to check the wiring connections on the rear taillights. The ground is a problem. You may find one of the wires on each side burned / melted due to bad ground. Have someone operate the brakes, turn signals, lights, etc while you watch from the rear ( or use your cellphone video recorder). If you see strange patterns in how the lights work, it's likely the ground. Not too hard to fix.
https://www.jaguarforums.com/forum/x...esolved-35083/
 
  #8  
Old 06-29-2019, 10:51 AM
Redline's Avatar
Senior Member
Join Date: Sep 2016
Location: Las Vegas, NV
Posts: 260
Received 127 Likes on 72 Posts
Default

Contact forum member John Sullivan at [email protected] He has rebuilt brake switches in stock or can rebuild yours asap for peanuts ($).
 
  #9  
Old 07-11-2019, 07:39 AM
SamtheSham's Avatar
Senior Member
Thread Starter
Join Date: Dec 2016
Location: S.W.Florida
Posts: 419
Received 82 Likes on 65 Posts
Default

I ended up replacing the switch, and the problem still persists. Checking now for possible problem in the microswitches in the 'J' gate area(connected to the shift/reverse switching. Will look at the headlight leveling connections if that doesn't work. All rear/backup/brake lights work fine.
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
govatos
XK8 / XKR ( X100 )
7
07-12-2019 07:31 AM
brgjag
XK8 / XKR ( X100 )
10
08-27-2016 09:31 PM
lbeagles
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
4
07-24-2014 05:45 PM
PerrysJag
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
2
02-19-2013 03:46 PM
swoop22
X-Type ( X400 )
11
11-04-2011 03:32 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: "Cruise control not avail/check rear lights"


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: