General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

CAN Bus troubleshoot

 
  #1  
Old 02-04-2019, 07:20 AM
Member
Thread Starter
Join Date: Nov 2018
Posts: 33
Likes: 0
Received 0 Likes on 0 Posts
Default CAN Bus troubleshoot

Hello,

I'm trying to fix a problem in the CAN bus ( U1900 and other node missing etc...)

I have 12.7 V on ignition off

I have 2.7 V on CAN_H and 2.4 V on CAN_L which seems to be good

But when i mesure the resistance between H and L , i have 0 ...

is it possible ? or my DVOM is dead ? ( or at least , not having his ohmmeter function ...)

Also , i don't seem to find the main connectors wiring, its like a big cube ... with many wires, one on right up from fuse box , and one on left, i don't find the name

Thx
 
  #2  
Old 02-06-2019, 06:12 AM
Veteran Member
Join Date: May 2009
Location: Yorkshire, England
Posts: 23,189
Received 3,416 Likes on 3,027 Posts
Default

It's you DVOM or how you use it - think about it: you can't have different CAN_H & CAN_L if the ohms are zero.
 
  #3  
Old 02-10-2019, 08:25 AM
Veteran Member
Join Date: May 2009
Location: home
Posts: 3,284
Received 584 Likes on 484 Posts
Default

Unless you have an SDD and know how to use it you are just shooting in the dark.
It's just WAY to complicated to try and troubleshoot a CAN bus with stone age tools.
.
.
.
 
  #4  
Old 02-11-2019, 03:45 AM
Member
Thread Starter
Join Date: Nov 2018
Posts: 33
Likes: 0
Received 0 Likes on 0 Posts
Default

Hello,

I have SDD ... i bought a new power supply 30 A 9mv ripple , reinstalled SDD, removed firefox ( SDD works better with Internet Explorer)

I ordered some piercing probes / Needle probes

Also I ordered new DVOM , i found 60 ohm between pin 6 and 14 from Data Link Connector and correct voltage

Next step is to test the CAN lines continuity between ABS/DSC module ( on MY2009 there seems to be only 1 module refered as DSC module) Junction Box

thx
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
davejdoyle
XK8 / XKR ( X100 )
32
05-06-2016 11:54 AM
ace911emt
X-Type ( X400 )
6
03-22-2012 10:57 AM
HectorM52
XJ XJ8 / XJR ( X308 )
4
01-04-2012 10:57 PM
tzvangel
X-Type ( X400 )
12
01-28-2011 02:20 PM
04blackxjr
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
7
09-27-2010 04:20 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: CAN Bus troubleshoot


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: