Jaguar Engines & transmissions Discuss performance / modifications / upgrades etc here..

92mm MAF installed. Yeah baby !!

 
  #61  
Old 05-19-2017, 12:08 AM
avos's Avatar
Veteran Member
Join Date: Apr 2008
Location: Europe
Posts: 3,176
Received 855 Likes on 614 Posts
Default

The 0.02 voltage is not good, and I would say something is wrong with the unit, as the start voltage should be much higher (don't know by head). I thought that maybe when there was flow (so once you start), the voltage would go up and the car could be running. Best is to do the same measurement with the stock MAF, and inform Chris of what's wrong.
 
  #62  
Old 05-19-2017, 02:42 AM
ET1
ET1 is offline
Member
Join Date: Sep 2013
Location: SF Bay Area
Posts: 88
Received 3 Likes on 3 Posts
Default

Thanks Avos, I'll do that tomorrow with the OE MAF..
 
  #63  
Old 05-19-2017, 03:12 AM
avos's Avatar
Veteran Member
Join Date: Apr 2008
Location: Europe
Posts: 3,176
Received 855 Likes on 614 Posts
Default

Np, the voltage should start from 0.6 ish something, so the meter isn't ok or an incorrect tune is loaded, so providing Chris the right start voltage should help him determine what could be wrong.
 
  #64  
Old 05-19-2017, 11:53 PM
ET1
ET1 is offline
Member
Join Date: Sep 2013
Location: SF Bay Area
Posts: 88
Received 3 Likes on 3 Posts
Default

I couldn't get the car to start and run for more than a second or two.

Reinstalled OE MAF, cleared codes and it runs perfectly. The voltage is 11.75 from the hot lead and the MAF signal (green lead to ground is a solid .68V..you called it.

I'm disgusted and sent the unit back for testing.

I followed the install directions EXACTLY this second go around as the miswiring was an expensive mistake. I took several close up pix for confirmation as you have seen. I did quite a bit of research on MAF wiring and problems today.
I wish I had done that before connecting the Pro M up the first time.

I posted the pic here and also fwded it to Pro M. I haven't gotten a response to the picture yet.

Thanks again for your advice

ET
 

Last edited by ET1; 05-19-2017 at 11:56 PM.
The following users liked this post:
deuce2000 (02-05-2018)
  #65  
Old 02-02-2018, 07:54 AM
deuce2000's Avatar
Veteran Member
Join Date: Jan 2012
Location: Grosseto, Tuscany, ITALY
Posts: 1,420
Received 251 Likes on 127 Posts
Default

going to buy it
 

Last edited by deuce2000; 02-02-2018 at 08:24 AM.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jimforrest (uk)
XK8 / XKR ( X100 )
22
02-28-2019 06:42 PM
10 XF Premium
XF and XFR ( X250 )
2
10-02-2015 09:22 PM
Lubrication
X-Type ( X400 )
3
10-01-2015 03:56 AM
mrplow58
XK8 / XKR ( X100 )
6
09-30-2015 08:56 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 92mm MAF installed. Yeah baby !!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: