Jaguar Forums Feedback & Suggestion Center Need help with Jaguar Forums? Ask here! Have a suggestion to help improve Jaguar Forums? Tell us here....THIS SECTION IS NOT FOR TECHNICAL QUESTIONS

signal switch not working

 
  #1  
Old 12-27-2014, 11:30 AM
Junior Member
Thread Starter
Join Date: Dec 2014
Location: Kingman, AZ
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default signal switch not working

Have a 1988 Jaguar that the turn signals are not working. Been reading up on the problem, something with the GEM modular not working. Can any one tell me where that is located? Everything else is working, could it just be a bad switch? Thank for any & all help - need this fixed ASAP
 
  #2  
Old 12-27-2014, 11:59 AM
Join Date: Apr 2012
Location: Summerville, South Carolina
Posts: 18,468
Received 2,892 Likes on 2,612 Posts
Default

Can you give us a little more info on the vehicle -so we can move this to the model specific section
 
  #3  
Old 12-29-2014, 04:33 PM
Junior Member
Thread Starter
Join Date: Dec 2014
Location: Kingman, AZ
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default no turn signals

Originally Posted by sklimii View Post
Can you give us a little more info on the vehicle -so we can move this to the model specific section
Not sure what else you need to know - it is a 1988 Jaguar that we just got - dont know anything about the car - except the turn signals are are working. The headlights, tail lights & brake lights all work. Just need someone to tell me where to look for a fuse or GEM module of switch that could solve the problem. THANKS
 
  #4  
Old 12-30-2014, 05:17 PM
GGG's Avatar
GGG
GGG is offline
Join Date: Dec 2011
Location: Durham, UK
Posts: 109,151
Received 10,342 Likes on 8,499 Posts
Default

Originally Posted by Dee Gee View Post
Not sure what else you need to know - it is a 1988 Jaguar that we just got ..........
Jaguar produced 3 different models in 1988. Does it look like A, B or C?

A. XJ40 (badged as XJ6)

signal switch not working-xj40.jpg

B. XJ6/XJ12 Series 3

signal switch not working-xj-series-iii.jpg

C. XJS (Coupe or Convertible)

signal switch not working-xjs.jpg

Totally different electrics on each!

Graham
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
D.K
XF and XFR ( X250 )
37
02-01-2019 01:44 PM
philwarner
XJ6 & XJ12 Series I, II & III
16
09-05-2015 10:05 AM
allenman85
F-Type ( X152 )
12
09-05-2015 09:10 AM
arnoldmilk
New Member Area - Intro a MUST
8
09-03-2015 07:42 PM
laserguy
X-Type ( X400 )
3
09-03-2015 02:02 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: signal switch not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: