S-Type / S type R Supercharged V8 ( X200 ) 1999 - 2008 2001 - 2009
Sponsored by:
Sponsored by:

Parking break issues

 
  #1  
Old 07-05-2019, 09:50 AM
Junior Member
Thread Starter
Join Date: Jul 2019
Location: Nashville TN
Posts: 2
Received 0 Likes on 0 Posts
Default Parking break issues

The car sat for awhile. Once it was started the break pads felt locked in place. After some moving forward and back the break freed up but now a warning light states "cannot apply parking break" and "cruise control not available". When the vehicle is driven an obnoxious beeping sound is heard from behind the steering wheel. I've read other threads stating it could be the PB module or switch... any suggestions?

 
  #2  
Old 07-05-2019, 10:09 AM
Veteran Member
Join Date: May 2009
Location: Yorkshire, England
Posts: 23,325
Received 3,441 Likes on 3,047 Posts
Default

Battery is #1 suspect.

You could try resetting the EPB once battery is fully charged / new and with engine running.

If that fails you probably need to R&R thee physical EPB parts (cables, motor, maybe the module too).

"Search" will get you what others did and even pics etc.
 
  #3  
Old 07-05-2019, 10:14 AM
Veteran Member
Join Date: Oct 2012
Location: Oregon
Posts: 1,981
Received 677 Likes on 525 Posts
Default

Originally Posted by jbelleye View Post
The car sat for awhile...
Hello, and welcome to the forum.

Big clue in your statement above. Before you do anything else, fully charge the battery with an automatic charger with at least a 10 amp output. After that, see if the car behaves itself.

This is a common issue, with more details here:

https://www.jaguarforums.com/forum/s...attery-193787/

 
The following users liked this post:
jbelleye (07-05-2019)
  #4  
Old 07-05-2019, 10:19 AM
S-Type Owner's Avatar
Senior Member
Join Date: Feb 2018
Location: San Francisco Bay Area
Posts: 442
Received 103 Likes on 83 Posts
Default

+1

You also might want to stop by the "New Member" forum and post a brief intro as one of our Moderators will likely chide you for not doing so prior to posting to a technical forum.

Welcome, BTW...
 
The following users liked this post:
jbelleye (07-05-2019)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MikeofBonsall
S-Type / S type R Supercharged V8 ( X200 )
6
12-02-2018 03:56 AM
keifmaane
S-Type / S type R Supercharged V8 ( X200 )
2
05-03-2014 01:52 PM
capitolexchange
New Member Area - Intro a MUST
6
04-22-2014 12:26 PM
ThomasX
X-Type ( X400 )
1
08-18-2010 04:47 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Parking break issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: