XJ XJ8 / XJR ( X308 ) 1997 - 2003

audio system

 
  #1  
Old 03-15-2019, 02:32 PM
Junior Member
Thread Starter
Join Date: Feb 2015
Location: new jersey, usa
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default audio system

Hi guys, old watcher here, first post in a long time. My cat's (2000 xj8) sound system has suddenly developed a problem. Seems I'm getting sound only from the rear passenger side speakers, from the radio and the CD player. The rear driver side and both front are silent. The sub-woofer sounds like it's working as well. I checked all of the connectors at the back of the amplifier and sprayed them with contact cleaner and they are solid. Is there anything I missed other than fuses? I've learned allot here just from reading and watching and would like your expertise. Thanks in advance.
 
  #2  
Old 03-15-2019, 07:40 PM
Highhorse's Avatar
Veteran Member
Join Date: Feb 2013
Location: Trying to escape Central Florida
Posts: 2,706
Received 978 Likes on 758 Posts
Default

First, bookmark this... JagRepair.com - Jaguar Repair Information Resource
...then you'll be able to get items like this guide to start tracing and testing your wiring... http://www.jagrepair.com/images/Auto.../jagxj1999.pdf

This sounds like your amp may have gone south, ...perhaps a cold solder joint or burnt board? If your sub (its not really a sub) is still working...congratulations...every one I've seen has disintegrated. I would seriously start considering the possibility of switching to a 3rd party head unit and speakers. The sound is better and the unit itself has the power of the OEM unit and amp.
But if your going to be old school hard core, then you need to review the electrical link and start testing amigo.
 
  #3  
Old 03-15-2019, 07:45 PM
King Charles's Avatar
Veteran Member
Join Date: Mar 2014
Location: North Carolina,USA
Posts: 3,666
Received 593 Likes on 481 Posts
Default

+1 on upgrading the entire likely sun baked lot. I went w/

Head Unit : Kenwood DPX501BT
Speakers : Rockford Fosgate P165 6.5" 2-Ways
Subs : Memphis Audio 12inch & Amp
 
  #4  
Old 03-15-2019, 10:19 PM
M. Stojanovic's Avatar
Senior Member
Join Date: May 2017
Location: Kuala Lumpur
Posts: 500
Received 259 Likes on 193 Posts
Default

Originally Posted by paddeo View Post
Seems I'm getting sound only from the rear passenger side speakers. The rear driver side and both front are silent. The sub-woofer sounds like it's working as well. I checked all of the connectors at the back of the amplifier and sprayed them with contact cleaner and they are solid. Is there anything I missed other than fuses?
There are no fuses that would cause the problem you are having. In addition to the connector into the amplifier (I presume you mean the amplifier in the boot/trunk meaning you have a Premium system), there are also in-line connectors for the speaker wires - IC3 (12-way) and four 12-way connectors (CA10, CA12, CA14 and CA16; these are at the gaiters for the door wiring loom going into the body posts) - see the diagram attached.

However, I suggest you do the following checks: 1) unplug the connector from the amplifier; 2) Identify the pairs of wires (coming out of the connector) which go to your non-working speakers based on the colour codes shown on the diagram (for example, YR and YU (yellow/red and yellow/blue) go to the Left Front door speaker, etc.); 3) touch repeatedly a 1.5 V battery to each pair of the speaker wires and listen for crackling from the speakers.

If you hear crackling, the problem is in the amplifier. If you don't, the problem is either in the speakers themselves or in the mentioned in-line connectors.


 
Attached Files
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jjsaustin
XF and XFR ( X250 )
34
11-14-2018 09:00 AM
H20boy
XJ XJ6 / XJ8 / XJR ( X350 & X358 )
35
10-15-2018 08:54 PM
Red October
XJ XJ8 / XJR ( X308 )
2
12-19-2012 11:27 AM
daboss085
PRIVATE For Sale / Trade or Buy Classifieds
0
07-11-2012 05:46 PM
androulakis
S-Type / S type R Supercharged V8 ( X200 )
2
12-04-2009 05:51 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: audio system


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: